2

When using various applications the cursor stops blinking after a few seconds of inactivity.

The symptoms:

For example - if you are typing in Notepad and stop typing in about 5-6 seconds the cursor stops blinking (and stays in "on" state). If you start typing again, or switch to another app and switch back to Notepad, or click with the mouse, or do other similar activities the cursor starts blinking again - until you make a little pause and then after 5-6sec it stops again.

The same happens in the Start->Run box (or pressing Win+R), happens in File Explorer when you are typing in the address bar, and various other built-in Windows apps.

It does not seem to happen within other third-party apps and browsers for example (e.g. Chrome and Mozilla) but does happen on the address bar in Edge.

Applicability:

This happens specifically on Windows 10 (and does not seem to happen on Windows 7 for example)

This does not appear to be hardware or machine specific. We observed the same on different machines from different manufacturers.

The question:

How to turn this off? We want the cursor to not stop blinking.

2

I found it - a registry setting:

Computer\HKEY_CURRENT_USER\Control Panel\Desktop\CaretTimeout

It defaults to (decimal) 5000 mSec, which is why the cursor (caret) stops blinking after 5 seconds of inactivity.

Solution was to changing that (DWORD) value to some extremely large number (e.g. 500M) and log off and log back on. With a value of 500M it will time out (stop blinking) eventually after several days of inactivity.

What I have not found yet is the documentation for that setting.

| improve this answer | |
0

First, the marker in text is termed a caret, as opposed to the marker on the rest of the screen that follows mouse or touchpad motion, which is the cursor.

Second, this is the nature of Microsoft Notepad; there is no setting to control caret blink. You could use another text editor, such as Notepad++, if you want to control the caret blink rate and size. Caret settings are shown below.

Notepad++ caret adjustment

| improve this answer | |
  • Thanks for the suggestions. My issue is not that I can't use Notepad and am looking for a replacement. I know I have alternatives, if needed I can switch from Windows to Linux too. But this is not my question. The issue is cursor stops blinking. It is not that it blinks fast or slow, or how to adjust it in Notepad++. I appreciate the suggestion but this is merely a workaround at most and not a solution to the issue. – Vladimir Strinski May 17 '19 at 18:34
  • @VladimirStrinski, the caret is controlled by the application. Notepad has no ay to adjust it. You would have to get the source code, modify it and recompile it to change the behavior of Notepad. It's like saying "Why can't my Lada go 0-100 km/h in three seconds?" It can't unless you rebuild it. – DrMoishe Pippik May 17 '19 at 21:57
  • I don't think it is an application-specific case. For example the Start->Run box - which application is this one? And then suddenly all Windows built-in applications beginning to exhibit the same symptoms? This is certainly a Windows-induced issue. Otherwise I agree that applications do have an option to manually control the caret, but this is not the case. – Vladimir Strinski May 19 '19 at 18:04
  • −1 for insisting that “caret” is the only correct term for the text cursor / insertion point — see here (look at the “Options tab”) and here — and for focusing on Notepad, when the question said that that was just one example of several situations where the problem occurred. – Scott Apr 8 at 20:07
0

Go to regedit and go to "Computer\HKEY_CURRENT_USER\Control Panel\Desktop" then you see a list, doubleclick on "CaretTimeout" and set the value to "ffffffff" hexadecimal. Reboot and your problem is fixed. (and mine also becouse i had the same problem)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.