0

The host system is an iMAC:

macOS Mojave
Version 10.14.5
iMac (Retina 5K, 27-inch, Late 2015)
Processor 4 GHz Intel Core i7
Memory 16 GB 1867 MHz DDR3
Graphics AMD Radeon R9 M395X 4 GB

VirtualBox:

Version: 6.08 r130520 (Qt5.6.3)
VirtualBox 6.0.8 Oracle VM VirtualBox Extension Pack

The virtual machine is Ubuntu 14.04. In the virtual machine I have installed the guest additions:

sudo apt-get install virtualbox-guest-dkms

I restarted the VM after installing this. The problem is that in the System Settings / Screen Display I still only see a resolution of 640 x 480 (4:3) with no option to select a higher resolution.

What haven't I done?

2 Answers 2

2

After searching the other posts I found a solution that works:

  • In the Ubuntu VM, open a terminal and type:

    sudo apt-get install virtualbox-guest-dkms
    sudo apt-get install virtualbox-guest-utils
    sudo apt-get install virtualbox-guest-x11 
    
  • With the VM running, use the Devices menu option which is available in the host operating system.

  • Select the option "Insert Guest Additions CD Image..."
  • Back in the Ubuntu VM, open a terminal and type:

    cd /media/<username>/VBox_GAs_6.0.8
    sudo ./VBoxLinuxAdditions.run
    

Once this has been done, shutdown and restart the VM.

Now everything is great!

0

If you still experience problems with setting resolution after setting resolution resizing to 'None' or 'Automatic' in VirtualBox -> Preferences -> Display and mounting GuestAdditions execute following command in guest's terminal:

sudo apt-get install --reinstall linux-image-$(uname -r)

It worked for me - guest was Ubuntu 18.04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.