0

I have an older Fujitsu Workstation (~2015) with a SSD and a larger harddrive. Originally it had Windows 7 installed on the SSD with the hdd as data drive. A few month ago I created a second Partition on the harddrive and installed ubuntu and centOS a few times. Somewhere I messed up, and Windows can't boot anymore. When I try booting from the SSD I get to a Grub Rescue shell. I tried the windows 7 automatic repair, wich 'succeded' with no effect. Then I tried in the rescue console bootrec /fixmbr, which did 'succed' but had no effect either. bootrex /fixboot gives 'element not fond', but bootrec /ScanOs does find the windows Installation.

The Output from uefibootmgr -v:

Boot0000* Diagnostic Program    FvVol(5c60f367-a505-419a-859e-2a4ff6ca6fe5)/FvFile(085e8cc2-8ec9-4666-bd2a-49d481e95fa7)
Boot0001* SAMSUNG MZ7LN512HCHP-00000    BBS(HD,,0x0)..BO
Boot0002* ubuntu    HD(1,MBR,0xfe764988,0x800,0x32000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0003* WDC WD2000FYYZ-50UL1B0    BBS(HD,,0x0)..BO
Boot0004* IBA GE Slot 00C8 v1550    BBS(Network,,0x0)..BO
Boot0007* TSSTcorp BDDVDW SN-506BB  BBS(CDROM,,0x0)..BO
Boot0008* MBA v14.0.6  Slot 0300    BBS(Network,,0x0)..BO
Boot0009* ubuntu    HD(1,MBR,0xfe764988,0x800,0x32000)/File(\EFI\UBUNTU\GRUBX64.EFI)..BO

Both Windows partitions are readable from Ubuntu.

Gparted shows a 100MB fat16 partititon with mountpoint /boot/efi (6.28MB used) on the SSD, and a 476GB ntfs partition.

Is there anything I can do, to restore my windows? There is some Software installed, which is an absolute PITA to reinstall, so I would rather not reinstall my windows.

  • If you have Windows 7 installed in UEFI mode why are you using tools/methods for BIOS/Legacy? – GabrielaGarcia May 15 at 16:31
  • Or maybe Ubuntu is? The problem is mixing modes. – GabrielaGarcia May 15 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.