2

I use my laptop, (1366 x 768) to access my desktop (1920 x 1080) through RDP. However, I've run into a bit of a problem.

When I connect remotely using fullscreen, it forces my server into my laptop's resolution (1366 x 768).

As you can see, both Windows Spy and the screenshot itself indicate that the resolution is only 1366 x 768.

Now, this is fine most of the time. However, I've found myself in a situation where I need to take repeated screenshots, and I need them to accurate reflect the resolution on screen of my server, not my client.

So, I changed my RDP file:

desktopwidth:i:1920
desktopheight:i:1080

But, when I still load into fullscreen, that doesn't matter. It still locks to 1366. When I load into windowed mode, then it loads the native resolution, but it's stuck in a tiny window, and even when I maximize it, I have to use the scroll bars and it's not utilizing as much screen area as I have available.

I can go full screen and use Super Pan, but that still requires me to scroll around.

I've tried forcing my laptop's resolution to 1920/1080 using Intel's Custom Resolution, and using CRU, neither of which have given any results.

Is there any way to fullscreen a Remote Desktop Session, keep the native resolution from the host, and squish (for lack of a better term) that space onto the client, without resizing?

I don't care if it looks good, I just want to be able to see everything.

Here is my RDP file

use multimon:i:0
desktopwidth:i:1920
desktopheight:i:1080
session bpp:i:32
winposstr:s:0,1,0,0,800,600
compression:i:1
keyboardhook:i:1
audiocapturemode:i:0
videoplaybackmode:i:1
connection type:i:7
networkautodetect:i:1
bandwidthautodetect:i:1
displayconnectionbar:i:1
enableworkspacereconnect:i:0
disable wallpaper:i:0
allow font smoothing:i:0
allow desktop composition:i:0
disable full window drag:i:1
disable menu anims:i:1
disable themes:i:0
disable cursor setting:i:0
bitmapcachepersistenable:i:1
full address:s:localhost:9878
audiomode:i:0
redirectprinters:i:1
redirectcomports:i:0
redirectsmartcards:i:1
redirectclipboard:i:1
redirectposdevices:i:0
autoreconnection enabled:i:1
authentication level:i:2
prompt for credentials:i:0
negotiate security layer:i:1
remoteapplicationmode:i:0
alternate shell:s:
shell working directory:s:
gatewayhostname:s:
gatewayusagemethod:i:4
gatewaycredentialssource:i:4
gatewayprofileusagemethod:i:0
promptcredentialonce:i:0
gatewaybrokeringtype:i:0
use redirection server name:i:0
rdgiskdcproxy:i:0
kdcproxyname:s:
drivestoredirect:s:
smartsizing:i:0
enablesuperpan:i:0

I've done experimentation with Super Pan, Smart Sizing, and every type of screen mode I can imagine, none of which give any results. I'm certain this can be done, because at one point, I had a window which did exactly what I'm describing, but it still showed my client's taskbar, etc, as though it were a windowed application.

3
  • You may wanna take the Update Edit to an answer if you found a solution.
    – CaldeiraG
    May 17, 2019 at 14:57
  • @CaldeiraG Thanks for the heads up, didn't think I was able to do that. Appreciate the help. May 17, 2019 at 19:09
  • No worries, you are encouraged to do so! Check Can I answer my own question? and welcome to Superuser!
    – CaldeiraG
    May 18, 2019 at 11:22

2 Answers 2

2

I find a solution I like better:

  1. Export an RDP file, from the client
  2. Edit the RDP file, and pay attention to three specific values: smart sizing:i:1, screen mode id:i:1, and desktopwidth/height
  3. In order to use higher-than-native resolution, you're going to want to set your desktopwidth/height to the desired resolution, and use screen mode id:i:1. This will open it as a window, BUT you can right click on the window bar and select 'Full Screen', which will full screen your session but preserve the resolution you're trying to use. You can also use the keyboard shortcut Ctrl + Alt + Break to make your RDP session full screen.

In addition, if you export the RDP file, you can automate all of this using AutoHotKey, like so:

Run C:\Users\Chris\Desktop\RDP Connections\Desktop Connect.rdp
WinWait ahk_exe mstsc.exe
Sleep 1500
Send ^!{CtrlBreak}

This will wait until you've launched the session, wait an extra 1.5 seconds, and then send the keyboard shortcut to maximize your window.

0

I was able to find a solution, but it's not ideal. The software Remote Desktop Manager does exactly what I'm looking for, but it's external software, and a little bit overkill (ie complicated) compared to just using RDP. If you've come to this thread with the same problem, I'd suggest checking it out, trying out the free version (or other versions you can find on various websites), and seeing if it does what you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.