2

I have been trying to get jupyter notebook to launch from the anaconda navigator and the terminal and it will not load. I can start it just fine using the terminal or the navigator but when it opens up on my browser all that I get is a landing page as below:

image of error page

The terminal out put after executing the jupyter notebook command is included below. Any help would be appreciated. I have tried uninstalling and re installing anaconda as well as uninstalling and re installing the jupyter notebook package but neither has resolved the issue.

base) jrbarboza08@penguin:~$ jupyter notebook
[I 17:54:20.508 NotebookApp] The port 8888 is already in use, trying another port.
[I 17:54:20.509 NotebookApp] The port 8889 is already in use, trying another port.
[I 17:54:20.509 NotebookApp] The port 8890 is already in use, trying another port.
[I 17:54:20.509 NotebookApp] The port 8891 is already in use, trying another port.
[I 17:54:20.510 NotebookApp] The port 8892 is already in use, trying another port.
[I 17:54:20.552 NotebookApp] JupyterLab extension loaded from /home/jrbarboza08/anaconda3/lib/python3.7/site-packages/jupyterlab
[I 17:54:20.552 NotebookApp] JupyterLab application directory is /home/jrbarboza08/anaconda3/share/jupyter/lab
[I 17:54:20.554 NotebookApp] Serving notebooks from local directory: /home/jrbarboza08
[I 17:54:20.554 NotebookApp] The Jupyter Notebook is running at:
[I 17:54:20.554 NotebookApp] http://localhost:8955/?token=97c1910620b824478c5a3e2f75c42aa1a731a11785efe9e8
[I 17:54:20.554 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
[C 17:54:20.648 NotebookApp] 

    To access the notebook, open this file in a browser:
        file:///run/user/1000/jupyter/nbserver-6247-open.html
    Or copy and paste one of these URLs:
        http://localhost:8955/?token=97c1910620b824478c5a3e2f75c42aa1a731a11785efe9e8
4
  • 2
    @muffin - have you tried using the http:// URL, instead of the file:// URL?
    – Attie
    May 11 '20 at 15:36
  • Please run $ ss -lt after you started jupyter and append its output to your question.
    – dirdi
    May 11 '20 at 16:27
  • At second glance, I noticed that the URL you entered inside the browser is different from the URL jupyer told you to open (...6247-open.html vs. ...7406-open.html). Please try again with the right URL.
    – dirdi
    May 11 '20 at 20:06
  • I'm curious about the "port in use" message. Is there another instance of jupyter running, or some other program using that port? Perhaps restarting the machine might work. Or you can specify a different port with jupyter notebook --port=8889 As dirdi said, watch out for that filename as it changes every time you relaunch jupyter.
    – Peter
    May 15 '20 at 2:21
0

You may try using

jupyter notebook --ip=0.0.0.0 --port=8888

Please post feedback.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.