0

I used macOS Sierra 10.12.6. I DON'T USE HOMEBREW! I tried to download from Vimeo with youtube-dl and got this:

ERROR: Unable to download webpage: <urlopen error [SSL: TLSV1_ALERT_PROTOCOL_VERSION] tlsv1 alert protocol version (_ssl.c:590)> (caused by URLError(SSLError(1, u'[SSL: TLSV1_ALERT_PROTOCOL_VERSION] tlsv1 alert protocol version (_ssl.c:590)'),))

It's because OpenSSL version supplied with macOS out of date. So I updated openssl like this:

$ curl -O https://www.openssl.org/source/openssl-1.1.1b.tar.gz

$ tar -zxvf openssl-1.1.1b.tar.gz
$ cd openssl-1.1.1b

$ ./config

$ make

$ sudo make install

After that, I check openssl version:

$ openssl version
OpenSSL 1.1.1b 26 Feb 2019

And check where is it:

$ which openssl
/usr/local/bin/openssl

But error exists anyway. Then I check what version python used:

$ python -c 'import ssl; print(ssl.OPENSSL_VERSION)'
OpenSSL 0.9.8zh 14 Jan 2016

It's old out of date version!

Question: how can I tell the python (and other apps that may use openssl) use the new version?

p.s. the python version is:

$ python --version
Python 2.7.10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.