I have Windows 7 64-bit running on a MacBook Pro in a Boot Camp partition. I am trying to pair with my Bluetooth Mighty Mouse and Apple wireless keyboard under Windows, but whenever I try to do so, here's what happens:

  1. While on the Add a device window, I turn on the mouse or press a key on the keyboard, and the mouse or keyboard shows up in the list of available devices.
  2. I click the device and then the Next button, and the window displays Connecting to device...
  3. Time passes.
  4. Eventually, I get this error message:

Adding this device to this computer failed

Adding the device failed resulting in an unknown error. The reported error code is 0x80070015.

Contact your device manufacturer for assistance.

I've run Windows Update and Apple Software Update. I've also tried reinstalling the drivers from the Snow Leopard DVD.

The mouse and keyboard both work fine when I boot into Mac OS X.

FWIW, after many, many repeated tries, I eventually got it to work. I don't know why. So while my problem is solved, I'd still like to get an "answer" as to why trial-and-error seems to be the only approach.

The keyboard, in particular, was hard to get set up. A few times, Windows would apparently recognize it and prompt me to enter the pairing code, but then it would time out after a couple of seconds (not long enough to enter the code). Grrrr.

  • 1
    Maybe this is a dumb question, but did you install the drivers from your OS X DVD in Windows? – trolle3000 May 25 '10 at 17:55
  • Yes, drivers from DVD installed prior to Apple Software Update. – Kristopher Johnson May 26 '10 at 0:16

This trick seems to work reliably if you have a Bluetooth device that pairs fine in OS X but not in Windows:

  1. Boot into Mac OS X and go into the System Preferences -> Bluetooth pane.
  2. Rename the troublesome device.
  3. Remove the troublesome device.
  4. Boot into Windows and pair the device. (This should now work, because the renaming and removing in OS X gets the device back into a state where Windows will pair with it.)
  5. Boot back into Mac OS X and connect the device, re-pairing it if necessary.

After this, the device should work fine in both OS X and Windows.


The devices may have exited discovery mode before Windows was able to complete the pairing process. I've had this problem happen before and the best thing to do is turn everything off and on again and go through the process as quickly as possible. You may have also had a problem with the mouse and keyboard thinking it was already paired. This might have happened because the computer's bluetooth device is identified by an id address. If it were already registered the headphones may be trying to connect while the PC is trying to pair.


I had a similar problem with a Microsoft Bluetooth Mouse 5000 on my HP laptop running Windows 7 and Ubuntu as a dual-boot. The problem happened after I had paired the mouse in both Windows 7 and then booted into Ubuntu and paired the mouse there.

When I rebooted back to Windows, the mouse was showing as paired and it was showing in the list of bluetooth devices, the mouse itself appeared to work (light flashing underneath) but when I moved it the cursor on the screen would not move.

I tried then reinstalling the software for it and re-pairing once more when I got the error 0x80070015. I searched on Google but the results shown ("Device Not Ready" error) did not seem to match my mouse's issue.

Things I tried were:

  • turning the mouse off and pairing it, no luck;
  • pressing the bluetooth button underneath the mouse while pairing, no luck;

I then thought that maybe if the mouse recalls that it is paired with the PC and tries to connect but the PC doesn't see the mouse paired and tries to pair then the solution would be to completely reset the mouse.

I then attempted to reset the mouse by turning it off, then turning it back on and then holding down the bluetooth button for 10s. The battery LED on the top of the mouse started to flash green and red. From there I just paired as default on MS Windows 7 and this fixed the problem.

Funny enough, Ubuntu does not show the same problem, I rebooted the machine once more and the mouse was still paired and working.

Hope this info helps...


After several tries and failures, I downloaded the drivers for the mouse and then it was recognized immediately and has kept working fine ever since.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.