1

I recently replaced the mobo on an out-of-warranty dell optiplex 9020. I then tried to update the BIOS to latest. When I run the BIOS update exe file, I get a message saying "Cannot Update a Optiplex 7020 with a Optiplex 9020 BIOS". So I realised that the mobo came with its own Service Tag, Express Service code, and is also identifying itself as a 7020. In order to change the service tag, I've tried:

  1. Asset utility just says "check format of tag, and remove setup password". I dont have any passwords set in BIOS.

  2. I tried the CMOS battery removal for 10min method. No difference

  3. I used the /f flag with the update exe, still can't force the update

  4. I learnt of a 'svctag' exe, but can't find it. Same for a serviceTag program on Linux.
  5. Tried Dell CCTK and Dell Command Configure utility -it only allows changing asset tag.
  6. There was a method talking about using /writehdrfile with the BIOS update exe, but it doesn't take that command option
  7. There is a jumper method for RTCST - but I'm not sure if it will reset service tag, haven't tried it yet.

So, any ideas on what else can be tried?

  1. I have the Hiren Boot CD - unfortunately the options to update Flash in UniFlash are disabled for some reason.
  2. Is there a way to use HBCD and edit the BIOS with a hexeditor?
  3. how do i extract the BIOS update file from the exe?
  4. Is there a way to change the system id and get the mobo to identify itself as a 9020?

thanks in advance

  • 2
    Dell motherboards, when they come from the manufacturer prompt you to perform a tattoo (not sure if that is the term they use) and at that time you program in the service tag and other critical info. It can be set once and that is it. Short of getting your hands on specific manufacturer only tools, it is NOT possible to do what you are asking. – Appleoddity May 17 at 3:11
  • Thanks The replacement board came off eBay, so i guess its toast. – aaaaarrrgghhh May 17 at 3:14
  • Just download the BIOS update for the 7020. – Appleoddity May 17 at 3:15
  • I should have listed that - yes i did it. but for some reason i'm getting random errors on memory configuration, and Windows keeps crashing with blue screens unpredictably. Either the mobo is faulty, or the system identifying itself as a 7020 is causing other issues. – aaaaarrrgghhh May 17 at 3:30
  • Double check the memory is seated properly. Run a bootable memory diagnostic disk and tap on the RAM while it is running, see if it crashes or gives errors. Let a few passes of mem tests run to make sure it is stable. I used to be in the repair business, I stopped buying motherboards on eBay because most are garbage boards people are “refurbishing” by baking them in their oven and other stupid ideas, popular sellers too. Very good chance the board is no good. I can appreciate wanting to repair an older computer but it’s just not worth it anymore. – Appleoddity May 17 at 3:35
0

I extracted a binary image via an SPI flasher from the SOIC Bios chip. While I was successful in neutering the intel Management engine, I was unable to change the service tag by going through the binary data with a hex editor and manually replace all mentions of the service tag. I replaced some, but it seems that there is another SOIC chip besides the main bios chip containing the Service tag.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.