0

My Nginx sites are currently a little bit wonky.

I have a reverse proxy to my public-facing hastebin instance that works fine. However I am trying to setup Outline, but it's redirecting to my Webmin instance. You can see via the following links:

Outline docs.greemdev.net is showing the content of admin.greemdev.net when it shouldn't be. Webmin is on port 10000 and Outline is on 3000.

Hastebin I'm not sure what I am doing wrong.

Link to my Nginx configuration for docs.greemdev.net and paste.greemdev.net:

nginx hastebin

If I need to provide any more of my configurations let me know.

2
  • Try removing the localhost restriction from the listen statement. May 17 '19 at 6:42
  • @RichardSmith I had omitted that previously, same issue. I just had that in because I thought it'd work. Nope.
    – Greem
    May 18 '19 at 4:25
0

"Solved"

I switched to Caddy.

Caddy offers automatic Let's Encrypt SSL encryption, as well as a less convoluted configuration file syntax. I switched over because Nginx was doing this to my other sites as well, and it was annoying me.

3
  • Thanks for closing the loop on your question. This would be more helpful to other readers with a similar problem if you could add a few sentences to explain how you decided on that solution, and why that's a good solution for you.
    – fixer1234
    May 18 '19 at 8:30
  • @fixer1234 Will do.
    – Greem
    May 19 '19 at 5:38
  • It sounds like Nginx was acting flaky, so you tried Caddy, and it doesn't exhibit the same problems? So maybe not that there's a specific feature you can point to that explains why Caddy works better, you just tried it and discovered that it does?
    – fixer1234
    May 19 '19 at 5:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.