5

At my work I have LAN1 of three twice interconnected monitoring PCs on Windows 7. Each PC has two network cards. The three pairs of IP address are the following:

PC1: 202.20.223.101 / 202.20.224.101
PC2: 202.20.223.102 / 202.20.224.102
PC3: 202.20.223.103 / 202.20.224.103

The "Default gateway" on PC1, 2 and 3 is empty. The subnet mask 255.255.255.0.

Also I have a router (ZYXEL Keenetic Omni) and the patch cords (red).

What I need is to have the "Remote Desktop Connection" to PC3 from office LAN2. On LAN2 we have Window Server 2008 as 192.168.1.1 and fixed IP addresses like 192.168.1.1 ... 50, subnet mask 255.255.255.0

diagram

Can this be achieved and what settings will allow me to do this as just plugging the router in between does not do the thing?

Thanks for any advice!

11
  • 7
    +1 for diagram. May 17, 2019 at 19:26
  • You could use a VLAN to see terminals in LAN2. Or put one of the terminals in LAN2 as a gateway and set a SSH tunnel there, forwarding ports.
    – Alfabravo
    May 17, 2019 at 19:41
  • 1
    The Blue device in the center of the picture with the antenna sticking out appears to be a wireless device. Is that an access point or a router? how is it hooked up? is there a WAN port and is it in use? From what I can see, you simply need to get port 3389 through this device. If it is a router then you need to setup port forwarding. If you are using it as a switch then you already have the access you need.
    – Larryc
    May 21, 2019 at 19:47
  • 1
    OK, there is still a lot of things that are not clear. I will make some assumptions and hope things work out. If not, then I will need more details from you. Your IP address is 192.168.1.5 your gateway is 192.168.1.1(?) you have an omni router at 192.168.1.24 and it is also connected to the 202.20.223.xxx network . If all of the above is true then this is how I would configure the forewording page: Description- RDP. Translate packets coming from- ANY. Translate address- 192.168.1.0 Mask 255.255.255.0 Protocol- 3389 etc... Translate to-202.20.203.102 Port 3389.
    – Larryc
    Jun 2, 2019 at 16:39
  • 1
    On your computer dont connect to 202.20.223.102. instead, connect to 192.168.1.24. the router will pass you on to 202.20.223.102 if everything is setup correctly. Make sure you have enabled remote access on the machine at 202.20.223.102, it must be set to allow your connection. Make sure you have a login and password for that machine. Good luck!
    – Larryc
    Jun 2, 2019 at 16:45

1 Answer 1

1

The alias does the magic. When I insert a router in the way of A1 line before PC3 the network 202.20.224.xx continues to work but in order to address the PC3 from the router I have to make PC3 the part of the router network - 193.168.2.1. So I assign the second IP address to PC3:

alias added

after that it becomes visible, and I register the host in the router:

enter image description here Then I create the port forwarding rule to access PC3 from outside the router as

enter image description here

Thus I also preserve the internet connection from LAN2 (192.168.1.0) to router area which is important.

The Keenetic support helped me out. Now I have to figure out how to gain access to the shared folders of the LAN2 from behind the router...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .