I exported a basic Cinema4D scene as XML (File > Export > Cinema 4D XML) then opened up the xml in Cinema4D and it loses the reference to the texture applied.

If I open up the original .c4d file and render it I can see my texture applied.

If I open up the exported .xml file and render it the texture is missing.

Any solutions ?


your XML is an ascii text file, or should be. Check it in any text editor and make the typical ctrl + f search, for example, with words like "texture" , "material" or better, the name of your jpg or whatever the file. (ie, skin.jpg ) . Never tried that with Cinema, but have used many xml files in 3D and most usual problem is about non relative or relative path being the cause, or other detail like that. An edit in the text editor and re-import might fix it.

  • I've opened up the document in TextMate and found a node with a reference to the texture, and path is correct. I tried adding an absolute path and nothing changed. Also, looking through the XML, I found some <basebitmap size='4363'> nodes containing hex values, which are embedded images I presume. I didn't understand if size refers to dimensions of the image(width*height) or the file size in bytes. I looked at the dimensions and file size of the texture used and couldn't find the numbers in the xml :( Any other hints would be useful at this point. Thanks. – George Profenza Jan 8 '11 at 1:35
  • Hmmm.... Bit clueless, then..Probably if had the file, cinema and all, might know, but that is not possible to do. But some ideas: Sometimes is just that import (in general, in softwares) forces some rendering or scene feature be non ticked as usual. Check materials, textures applied, etc. Also..Have you tried putting texture in exact same folder, but before, previous to export. All, xml , scene file, and textures, in same folder, export, then import the xml. If no worky, try editing that xml to have no path, or ./file.tga , or just file.tga, etc. I'll tell you if I think of anything else... – S.gfx Jan 8 '11 at 21:14
  • Also, check the settings, and do trial and error, both of the xml exporter settings, as the importer, till you catch it. Don't give up as it tends to get solved. First measure, tho, that I would have taken, is browse the web to check if is a known problem, or a importer or exporter issue for that cinema plugin or feature. I don't know, as I don't use Cinema,(used it a bit long ago), but is again the general way to do for saving you hours of effort ;) I'll check back for if it worked... – S.gfx Jan 8 '11 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.