36

LibreOffice Calc Version 5.2.7.2.

I have everything I can find under Tools -> AutoCorrect turned off.

However, I still see capitalizations in certain cases.

Is there anything more I need to turn off to completely disable it?

It seems to be related to hyphens. Some strings with hyphens separating words such as this in a cell "foo -- bar -- baz" will capitalize bar to Bar. However, similar sentences, in a new cell, will not experience this behavior.

3
  • Can you provide examples of the capitalization you see? Calc doesn't do much in terms of grammar and similar language correction. Your description would include things like capitalization of the letters in function names.
    – fixer1234
    May 19, 2019 at 3:24
  • 1
    I also encounter this problem. If I enter test in a cell, it doesn't capitalize, but if I enter test-me, it will capitalize the t. Hyphens seem to trigger this behaviour. Even without hitting enter, if you type a word with a hyphen then hit space, it will capitalize the hyphenated word if its the first word. Jun 3, 2019 at 17:53
  • 1
    @dennisbjell I also get this behavior from hyphens. I didn't realize at first what caused it, but your comment made me realize what it was that actually did it. Jun 3, 2019 at 20:52

2 Answers 2

37

Deactivate the following option:

Tools > AutoCorrect Options... > Options > Capitalize first letter of every sentence

LibreOffice Calc: Capitalize first letter of every sentence

It seems that it doesn't typically trigger (i.e., I can put a cell that contains table, or another one that contains this is a message and nothing autocorrects). But under certain circumstances, it is indeed triggered (e.g. when you put this-notasentence, t is capitalized). I am not sure why LibreOffice decides that having a hyphen means that it is a sentence and thus should be triggered.

It seems a misbehaviour of LibreOffice, or a bad heuristic. I am not sure if that's your specific case, but for sure it is what was happening to me, @dennisjbell and @AlphaCentauri.


@m93a comments may be relevant: If you are using LibreOffice version >=7, menus may be moved, and you can access the traditional ones by

⚙️>User Interface and change to Standard Toolbar

And change back by:

View>User Interface>Tabbed

7
  • I don't see „AutoCorrect Options“ anywhere in Tools. This is what I see: i.imgur.com/Ah6ihxb.png
    – m93a
    Dec 12, 2020 at 10:36
  • @m93a you have a fancy menu which doesn't resemble mine at all. Are you really using LibreOffice Calc? Can't you access the old-fashioned text menu? Sorry, no idea what I am looking at. I am using LibreOffice 6.4.6.2 (Ubuntu 20.04) Dec 14, 2020 at 15:49
  • 1
    I had to go to ⚙️>User Interface and change to Standard Toolbar, then I could access the same menu you're reffering to. After that, I changed back to View>User Interface>Tabbed. I'm on LibreOffice 7.0.2.2 (from Flathub). The new Tabbed interface probably doesn't contain all the new functionality then. Good thing I can change back to the legacy UI.
    – m93a
    Dec 16, 2020 at 8:00
  • 1
    Good to know! Added that to the answer for potential future readers Dec 16, 2020 at 19:59
  • 1
    This is the answer. I have allowed myself to add a screenshot of the dialog in question. Mar 31, 2021 at 10:35
0

I fail to see how the answer, or comments, given so far solve the problem when an hyphen is involved. That could be due to not being a native English speaker. In any case, I find the answer to a question that concentrates on the hyphen issue to fully solves that particular issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .