1

I am a freelancer and I use my personal computer for work. I use Windows 10 and I used a cisco VPN client to connect to my clients network and I guess it somehow messed up my computer.

When I enter undefined url with slashes into the browsers address bar it redirects me to my clients website instead of google search or DNS error. It happens in browsers Google Chrome, Firefox, Microsoft Edge, Opera.

  • a/bbb/ccccc/ redirects me to company.com/bbb/ccccc/
  • /a/abcd redirects me to company.com/abcd
  • /abcdefgh/ redirects me to company.com
  • /ababababab/abbccbcb/ redirects me to company.com/abbccbcb/

I guess it somehow changed something in my computer and I dont know what to look for and how to fix this.

  • I dont use a proxy server.
  • There is nothing in my hosts file.
  • I have a manual IPV4 address and dns server settings from my internet provider.
  • I dont use a homepage in my browsers.

Any ideas how to fix this? Please help I am really desperate.

Edit: Thanks to @grawity I figured out that the issue might be caused by company.com in the DNS Suffix Search List. But I still dont know how to get rid of it.

In the output of ipconfig/all there is my clients website in DNS Suffix Search List.

Windows IP Configuration

Host Name . . . . . . . . . . . . : DESKTOP-ABC123
Primary Dns Suffix  . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : company.com

nslookup asdfghjkkll output (I changed the values for privacy):

Server:  my.internet.provider.server.com
Address:  192.168.255.1

Non-authoritative answer:
Name:    asdfghjkkll.company.com
Address:  66.77.88.99

nslookup asdf. output:

Server:  my.internet.provider.server.com
Address:  192.168.255.1

nslookup /abcdefgh/asdasd output:

Server:  my.internet.provider.server.com
Address:  192.168.255.1

Non-authoritative answer:
Name:    /abcdefgh/asdasd.company.com
Address:  66.77.88.99

Edit2: I figured it out. I had to remove the company.com value from registry HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\SearchList

  • Could you post the output of ipconfig /all as well as nslookup asdfghjkkll, nslookup asdf. (the dot is important), etc. from Command Prompt? – grawity May 19 at 12:51
  • Thanks a lot for your comment. I updated my question with the command outputs. It helped me to figure out what might cause the problem. Unfortunately I still dont know how to get rid of it, but it pointed me into right direction. Thank you thank you thank you. Do you, by any chance, happen to know how to remove the company.com record from the DNS Suffix Search List? – VertexLooper May 19 at 13:47
  • Nevermind I figured it out. I removed the value from registry from HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters. Thanks a lot @grawity – VertexLooper May 19 at 13:59
  • @VertexLooper Since you found a solution, it would be helpful to post it as a self-answer (preferable to the current edit into your own question) – Anaksunaman May 19 at 17:59
1

It was because of the DNS settings. I ran these commands from command prompt.

ipconfig/all

nslookup asdfghjkkll

nslookup asdf.

Thanks to that I figured out that I have a company.com in DNS Suffix Search List. Solution was to remove the company.com value from registry HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\SearchList

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.