5

I spent few days trying to install the Windows 10 ISO on my laptop:

I reset my BIOS settings, since it didn't work, yet still nothing. The USB doesn't appear in the BIOS menu.

Any suggestions?

4
  • Windows 10 is known to have issue if the USB media is made using any tool except the official Microsoft one. Have you tried that?
    – acejavelin
    Commented May 19, 2019 at 13:01
  • I didn't knew there was one. I searched on the net and can't find it, could you please tell me the name, or give the link. Thank you very much
    – Hamza Ince
    Commented May 19, 2019 at 13:05
  • Hi, I found out why I couldn't get the tool, it was because i wasn't on windows, so I've created a Windows 10 Virtual machine and downloaded the tool, I used it to format my USB, but I still can't the USB in the BIOS menu. Thank you for the suggestion. :)
    – Hamza Ince
    Commented May 19, 2019 at 20:02
  • If your PC or your BIOS are too old you might have an issue there. Some older motherboards might not recognize certain flash drive sizes. Above some threshold.
    – cybernard
    Commented Dec 25, 2020 at 19:14

9 Answers 9

1

Some BIOSes only re-enumerate USB drive 'types' on a cold boot. This means that if you change the partition\format structure of the USB drive, on some systems you must power them off and on again. If the system always stays on and you use crtl-alt-del or restart to begin a USB boot session, the BIOS may not 'notice' that you have changed the 'type' of partition. For instance, Windows will format a raw, unformatted USB flash drive as a floppy drive (no MBR). This won't MBR-boot correctly. If you use a new partition/format tool to change the partitions to a HDD MBR type of drive, the BIOS will still treat the USB drive as a USB:FDD drive and not a USB:HDD drive unless you reset the CPU or power-off and in again. This type of BIOS is rarely found these days, but it is worth remembering this 'gotcha'!

1

Possibly your USB Stick is recognized as a HDD instead of as a USB device.

In you bios menu, when you pick the boot priority, you have the option to chose between USB, HDD and FDD drives. However, additionally, you can select the HDD to boot from in a separate menu on the boot menu page. Go into that menu, and check if your USB stick is listed next to the HDD drives in your system.

0

Just like @SSi said, BIOS is somehow did not recognice that USB types have changed from GPT to MBR. Maybe it could help..

  • I plug in my USB Bootable, then i go to USB Configuration in BIOS.

  • In the Mass Storage Devices, I changed the USB types to "Forced FDD", Save & Exit.

  • Then go to BIOS again and change the Boot Priority of USB to the top , Save & Exit.

Then restart, it work for me.

0

Try to connect your pen drive in a USB 2.0 connector. Sometimes the bios does not recognize the newer protocol.

The USB 3.0 connectors are blue. Connect in one that is not blue and try again.

My computer does not recognize the card reader.

0

I had the same problem and managed to boot from the card reader after turning off secure boot and turning on legacy boot.

Here was my Bios configuration:

Bios configuration

Beware: when I reverted this configuration I had to restore the OS.

1
  • Secure boot is only compatible with UEFI; and also secure boot can prevent you from booting if you dual boot with a non-MS OS (like linux). If you needed to enable legacy mode to do your install that means you're booting into BIOS mode (not UEFI mode)- in which case turning legacy mode off/secure boot back on would kill your system/prevent you from booting into your newly installed OS. Just leave secure boot off/legacy boot on as default config if you do any sort of messing with your boot configuration.
    – boog
    Commented Sep 13, 2022 at 13:56
-1

Maybe your bios is set to 'Legacy Boot' and you are trying to boot from 'UEFI Boot' usb or vice versa. There should be an option in bios to change this.

-1

I found the problem, but still don't get it.

I tried to boot my key on an another laptop, and it worked, the other PC could boot on my USB flash drive.

I thought it might have been either me who hadn't properly set the BIOS or the computer at fault.

But, what I did next, was using an another USB key with my PC, and it also worked. I don't know why, but my computer and my USB flash drive didn't worked together.

-2

I encountered a similar problem where the F12 boot selection menu would not display the USB boot option. @SSi's solution worked for me. I powered down the PC, removed the USB drive, reinserted it and powered back on. That worked, and the USB drive showed up in the F12 boot menu. I was able to successfully install the OS.

-3

Plug in the USB before entering the BIOS menu, and check whether the USB is listed under "Hard Drives" instead of "Removable Devices" (the exact wording may be slightly different). If it is listed with the hard-drives, move the USB to the top of the list of hard-drives. Then, in the "boot priority" menu, select "Hard Drive" and not "Removable Drive".

I'm not sure why the BIOS failed to detect my USB drive as a USB drive, but this solution worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .