0

I spent few days trying to install the Windows 10 ISO on my laptop:

I reset my BIOS settings, since it didn't work, yet still nothing. The USB doesn't appear in the BIOS menu.

Any suggestions?

  • Windows 10 is known to have issue if the USB media is made using any tool except the official Microsoft one. Have you tried that? – acejavelin May 19 '19 at 13:01
  • I didn't knew there was one. I searched on the net and can't find it, could you please tell me the name, or give the link. Thank you very much – Hamza Ince May 19 '19 at 13:05
  • Hi, I found out why I couldn't get the tool, it was because i wasn't on windows, so I've created a Windows 10 Virtual machine and downloaded the tool, I used it to format my USB, but I still can't the USB in the BIOS menu. Thank you for the suggestion. :) – Hamza Ince May 19 '19 at 20:02
0

Maybe your bios is set to 'Legacy Boot' and you are trying to boot from 'UEFI Boot' usb or vice versa. There should be an option in bios to change this.

0

I found the problem, but still don't get it.
I tried to boot my key on an another laptop, and it worked, the other PC could boot on my USB key.
I thought it might have been either me who hadn't properly set the BIOS or the computer at fault.
But, what I did next, was using an another USB key with MY pc, and it also worked, I don't know why, but my computer and my USB key didn't worked together.

0

Some BIOSes only re-enumerate USB drive 'types' on a cold boot. This means that if you change the partition\format structure of the USB drive, on some systems you must power them off and on again. If the system always stays on and you use crtl-alt-del or restart to begin a USB boot session, the BIOS may not 'notice' that you have changed the 'type' of partition. For instance, Windows will format a raw, unformatted USB flash drive as a floppy drive (no MBR). This won't MBR-boot correctly. If you use a new partition/format tool to change the partitions to a HDD MBR type of drive, the BIOS will still treat the USB drive as a USB:FDD drive and not a USB:HDD drive unless you reset the CPU or power-off and in again. This type of BIOS is rarely found these days, but it is worth remembering this 'gotcha'!

-2

Plug in the USB before entering the BIOS menu, and check whether the USB is listed under "Hard Drives" instead of "Removable Devices" (the exact wording may be slightly different). If it is listed with the hard-drives, move the USB to the top of the list of hard-drives. Then, in the "boot priority" menu, select "Hard Drive" and not "Removable Drive".

I'm not sure why the BIOS failed to detect my USB drive as a USB drive, but this solution worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.