1

I have a Dell Precision M4600 laptop with Nvidia Quadro 1000M graphics.

Most desktop apps which use GPU rendering do not work correctly for me, for example Slack, Steam or some apps which use modern Electron platform (I see a blank or transparent window). For them I use settings or flags to use CPU or integrated card instead of GPU, but for some other apps (3D rendering or games) I have no workarounds rather than use integrated card.

I am not sure when this issue happened exactly, but it looks like it is either Windows update, BIOS update (Revision A19) or GPU driver update. But I could not find how to restore working GPU with different Win10 versions and different GPU drivers and I am too afraid to downgrade the BIOS.

I contacted Nvidia support, but they are unable to say anything besides: "Try this driver, try another". I've tried installing different versions 412.36, 416.78, 425.51 (by support suggestions) but all of them told me my system is incompatible. Latest driver I can at least install is 377.55.

I tried also starting in Safe Mode to test how Steam works: it works fine with 'Enable GPU rendering' but I am unsure how to tell if it is not an integrated card.

Is there any common solution or at least some explanation to this problem? Any help is appreciated.

  • I also got this issue few times when manually removed video card during disassembly – Yegor Androsov Dec 29 '20 at 16:33
0

It looks like BIOS update enabled some setting called 'Optimus', gpu switching technology. Disabling it dropped drivers for both nvidia and intel. After launching GeForce Experience app, it successfully installed correct driver and it works as before!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.