1

This question already has an answer here:

I put together a build, and I'm having some issues. When I boot up the PC all fans and LEDs come on, but nothing ever pops up on the screen.

The manual states I should be prompted with a BIOS screen. It also says some beeps should come through my audio, but there's been no sound. I've tried taking the GPU out and booting that way, but there's no change except that a white LED on the motherboard stays on.

From what I've read that'll stay on until a GPU is installed. I've also tried replacing the RAM with RAM from a different computer, but there's still no change. I've also tried booting with a single stick of RAM. Customer support stated that my RAM is likely the issue, but there wasn't much more said than that.

Does anyone have some other troubleshooting or likely causes that I should look into? It seems like everything is starting up as intended and that it just doesn't display anything on the monitor.

Specs:

  CPU: AMD - Ryzen 7 1700X 3.4 GHz 8-core processor
  RAM: G.Skill - Ripjaws V Series 16 GB (2 x 8 GB) DDR4-3200 memory
  SSD: Samsung - 860 EVO 500 GB 2.5" SSD
  PS: Corsair - RMx (2018) 750 W 80+ gold certified fully modular ATX power supply
  Motherboard: Asus - ROG STRIX B450-F gaming ATX AM4 motherboard
  CPU Cooler: Thermaltake Frio silent 14
  GPU: MSI Armor Radeon RX570

Link for pictures of the build https://imgur.com/a/oI9iTQC?

marked as duplicate by harrymc, fixer1234, jonsca, karel, Mureinik May 20 at 5:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • In order to hear any beeps. You need to plug in a PC speaker like this: imgur.com/a/gUaMhPq Your motherboard won't just beep automatically. Ram is normally not the issue with these situations, it's either the CPU or Motherboard. And since the rate of CPUs being at fault is ridiculously low. I suggest ordering another Motherboard and test that. It would be nice to see your computer build, maybe you missed a power plug somewhere. – Sickest May 19 at 21:04
  • Gotchya, I'll look through and see if I have a similar speaker floating around anywhere. I'll take a few pictures of my build and post them here when I get back. – user406955 May 19 at 21:40
  • Any OS installed? If so what? – Moab May 19 at 23:00
  • @Moab need it working for a newbuild OS to be installed. – JohnnyVegas May 20 at 5:51
  • @Moab I haven't installed an OS yet. I've got an OS on a USB, but I haven't even been able to get the BIOS to show up yet. I added a link for pictures. – user406955 May 21 at 3:28
1

I would suggest testing with only 1 RAM Stick from now on to exclude as many things as possible and make finding the error more efficiently. The GPU is needed in order to get you an image because your Ryzen is without an integrated GPU. Unplug the HDD/SSD and be sure to have all of your psu cables right. Also be sure the graphics card is not the issue. As mentioned by others you need a piezzo buzzer to connenct to your mainboard next to the pwr_btn pin etc. Please post pictures if possible for further troubleshooting. Cheers

  • "I've also tried booting with a single stick of RAM." 1+ But... Nice catch on the GPU being needed. I keep forgetting there are CPUs that don't have a GPU integration inside them. – Sickest May 19 at 21:04
  • me too... im no friend of 2400g because half of the processor still is a useless GPU when i decide to buy a video card... – insertRandomName May 19 at 21:27
  • @insertRandomName added a link for pictures imgur.com/a/oI9iTQC? – user406955 May 21 at 3:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.