0

I killed some tasks on my laptop because my fan was to loud and everything is working, except some parts. I am not anymore administrator of my PC, so I cannot install nothing. My TaskManager doesn't work, error is "The service cannot be started, either because it is disabled or because it has no enabled devices associated with it". When I try to run something from start->run, for example to run some services, regedit, gpedit.msc (that are some advice from other topics similar to this one) it doesn't work. For every task I got the same message:

"The service cannot be started, either because it is disabled or because it has no enabled devices associated with it"

I cannot use system restore, because I got the same error. (I found some option for use system restore - with ctrl+alt+del, and restart+shit down, but it is without point to the time where this happen).

  • Yes, it is the same – iviviviviv May 20 '19 at 17:19
  • 1
    What does “killed some tasks” mean? – Appleoddity May 20 '19 at 17:29
  • When TaskManager worked I selected in it and clicked End Process. – iviviviviv May 20 '19 at 17:36
  • If that is all you did then a restart will fix the problem. So killing some tasks did not cause this problem. – Appleoddity May 20 '19 at 18:20
  • Restart did not solve my problem. Maybe I also stopped some services. When I want to get in services, from start->services, I got same error – iviviviviv May 20 '19 at 18:31
1

I really don't think you can cause this problem by just killing some tasks by using task manager.

I think task manager disabled from registry somehow.

To enable it you can try :

1. Click on Start button.

2. Type regedit in Start menu search.

3. Select registry editor in search.

4. in the Registry Editor browse for the following keys. 
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System
HKEY_USERS\.default\Software\Microsoft\Windows\CurrentVersion\Policies\System

5. Look for a DWORD value "DisableTaskMgr" in right-side pane. If you find it, delete it.

6. Now check if the Task Manager will be enabled.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.