0

I install nexus3(Nexus Repository 3.16.1-02) repository and create pypi repository. pypi repo

and in my machine(centos 7) create repo file.

[Nexus_PYPI]
name= PYPI
baseurl= http://192.168.190.138:8081/repository/pypi-2/
gpgcheck=0
enabled=1

When update yum repolist with command yum repolist get this error. http://192.168.190.138:8081/repository/pypi-2/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

and when I want to install package pip, I can't and get this error.

[root@zk-kafka2 ~]# pip install kafka-utils
Collecting kafka-utils
  Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'ProxyError('Cannot connect to proxy.', error('Tunnel connection failed: 404 Not Found',))': /simple/kafka-utils/
  Retrying (Retry(total=3, connect=None, read=None, redirect=None)) after connection broken by 'ProxyError('Cannot connect to proxy.', error('Tunnel connection failed: 404 Not Found',))': /simple/kafka-utils/
  Retrying (Retry(total=2, connect=None, read=None, redirect=None)) after connection broken by 'ProxyError('Cannot connect to proxy.', error('Tunnel connection failed: 404 Not Found',))': /simple/kafka-utils/
  Retrying (Retry(total=1, connect=None, read=None, redirect=None)) after connection broken by 'ProxyError('Cannot connect to proxy.', error('Tunnel connection failed: 404 Not Found',))': /simple/kafka-utils/
  Retrying (Retry(total=0, connect=None, read=None, redirect=None)) after connection broken by 'ProxyError('Cannot connect to proxy.', error('Tunnel connection failed: 404 Not Found',))': /simple/kafka-utils/
  Could not find a version that satisfies the requirement kafka-utils (from versions: )
No matching distribution found for kafka-utils

how can I use pypi repository proxy in nexus in install pip pakages? thanks.

0

In order to use pip and PyPI on your machine, you'll need to configure a pip.conf not a create repo file. See https://help.sonatype.com/display/NXRM3/PyPI+Repositories#PyPIRepositories-ConfiguringPyPIClientTools specifically "Download, search and install packages using pip" subsection.

PyPI has its own metadata and does not use the one detailed so the errors returning (404) are 'correct'.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.