2

I'm having a couple of issues with mounting drives in WSL (Win10 Linux Subsystem).

I have a network share mounted on drive M: locally - and I have read/write access in Windows.

When I try and mount it using WSL:

$ sudo mount -t drvfs M: /mnt/m
mount: /mnt/m: cannot mount M: read-only.
$

I tried different mount options, still the mount always gets rejected with "read-only". (At the same time, mounting my network home works fine) And mounting a different network share also works; but can I find out, what's different about this network share? ..and - any idea of how to get around it? (Particularly given, that I DO have access to the drive within windows)

4
  • Did you try the wsl.conf method?
    – Biswapriyo
    May 21, 2019 at 8:13
  • doesn't seem to help; I also tried adding the suggested "metadata" option separately at mount time - same problem.
    – Torinarg
    May 21, 2019 at 8:48
  • Strange thing about the error message - why is the "read-only" a problem? Even if I specify mount option "ro" (read-only), it still doesn't mount the share with the same error message "read-only". The same happens when trying to mount with option "rw"...
    – Torinarg
    May 21, 2019 at 8:50
  • btw - has anyone else even seen this issue?
    – Torinarg
    May 21, 2019 at 18:20

1 Answer 1

0

In my case, I met "cannot mount: read-only" issue when I tried to mount other network drive in WSL.
But I solved by writting address number directly instead of Server name.


~$ smbclient -L 192.168.1.1 -U% <br/>
WARNING: The "syslog" option is deprecated   

        Sharename       Type      Comment   
        ---------       ----      -------    
        ebook           Disk      ipTime1TB's ebook in ipTIME External   

        Server               Comment 
        ---------            -------    
        RT-AC68R-F528        RT-AC68R-F528    

        Workgroup            Master         
        ---------            -------  
        WORKGROUP            RT-AC68R-F528

~$ mkdir -p ~/my_mount/ebook

~$ sudo mount -t drvfs //RT-AC68R-F528/ebook ~/my_mount/ebook<br/>
mount: /home/catholic2020/my_mount/ebook: cannot mount //RT-AC68R-F528/ebook read-only.<br/>
<3>init: (2018) ERROR: UtilCreateProcessAndWait:360: /bin/mount failed with status 0x2000<br/>
No error information<br/>

~$ sudo mount -t drvfs //192.168.1.1/ebook ~/my_mount/ebook      
~$

goodluck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .