1

I have installed Flatpak recently on my Debian Testing System (current Buster) and now tried to install DeltaChat. But after a successful installation I cannot launch the app, instead Flatpak returns 159 as exit code. I have also tried to run Spotify or VS Code OSS with the same result. I also tried to install the apps in system (without --user) instead of user giving the same result.

With verbose enabled, Flatpak does also not really indicate why it is crashing:

$ flatpak --user -v run chat.delta.desktop; echo $?
F: Opening user flatpak installation at path /home/zocker/.local/share/flatpak
F: Opening user flatpak installation at path /home/zocker/.local/share/flatpak
F: No installations directory in /etc/flatpak/installations.d. Skipping
F: Opening user flatpak installation at path /home/zocker/.local/share/flatpak
F: Opening system flatpak installation at path /var/lib/flatpak
F: Cleaning up unused container id 1289461851
F: Allocated instance id 3320985649
F: Add defaults in dir /chat/delta/desktop/
F: Add locks in dir /chat/delta/desktop/
F: Allowing dri access
F: Allowing homedir access
F: Allowing x11 access
F: Allowing pulseaudio access
F: Pulseaudio user configuration file '/home/zocker/.config/pulse/client.conf': Fehler beim Öffnen der Datei »/home/zocker/.config/pulse/client.conf«: Datei oder Verzeichnis nicht gefunden
F: Running 'bwrap --args 30 xdg-dbus-proxy --args=32'
F: Running 'bwrap --args 30 /app/bin/run.sh'
159

The missing pulseaudio configuration file is not the reason I think because Flatpak continues to launch the apps and touch ~/.config/pulse/client.conf causes only this single line to disappear.

Thank you for your help!

2
  • After you installed, did you log out and log in again?
    – fixer1234
    May 23, 2019 at 2:53
  • @fixer1234 Thanks for your suggestion, but even a full system reboot does not change anything. May 23, 2019 at 12:25

0

You must log in to answer this question.

Browse other questions tagged .