I use Windows10x64 to create Hyper-V VM with Linux Mint 19.1 cinnamon on board. When the os was installed I found that the video used only software acceleration (without any hardware acceleration that makes the vm slow). Also, doesn't work with the clipboard and the screen resolution change when I change the VM window.

How to fix this issue?

(with vmware I just set up vmware tools and all things described above works)

  • Vmware working slow? Commented May 22, 2019 at 17:44
  • 1
    Mint isn't a supported Linux OS, I'm not sure if they've (LinuxMint) done any work with Cinnamon for Hyper-V, or have included the LIS in the kernel. Updating LM to the azure kernel doesn't seem to make a difference for me. See: docs.microsoft.com/en-us/windows-server/virtualization/hyper-v/…. If you want Linux in Hyper-V, I'd suggest another distro, or use VirtualBox or VMware Workstation if you need LM. You could try XFCE instead of Cinnamon and that may work under Hyper-V.
    – essjae
    Commented May 22, 2019 at 18:42

3 Answers 3


I've been able to successfully install Linux Mint in a gen 2 Hyper-v VM. I used the following Powershell script published by Chris Lowe to create the VM:

        Creates a Hyper-V Virtual Machine suitable for running Debian.
        This PowerShell script creates a new Hyper-V Generation 2 Virtual Machine
        that is suitable for installing and running Debian. The default hardware
        configuration set by this script is as follows:
            - 4 Processor Cores
            - 2GB Static Memory
            - 127GB Dynamic Hard Disk
            - 1 Network Adapter
        In addition, a virtual DVD device is added for to the Debian installation ISO file.
        File Name   : Debian_Hyper-V.ps1
        Author      : Chris Lowe
        Prerequisite    : PowerShell V2

# Adjust the following variable values as required

$VM_Name = "LinuxMintMate"
$VM_ISO = "D:\Downloads\Linux\linuxmint-19.1-mate-64bit.iso"
$VM_ProcessorCores = 4
$VM_MemorySize = 16GB
$VM_DiskSize = 127GB

$VM_DiskPath = (Get-VMHost).VirtualHardDiskPath
$VM_Adapter = (Get-NetAdapter -Physical | Where-Object {$_.Status -eq 'Up'} | Sort-Object $_.LinkSpeed | Select-Object -First 1).Name
# If (((Get-VMSwitch -SwitchType External).Name) -eq $null) {New-VMSwitch -Name 'External' -NetAdapterName $VM_Adapter -AllowManagementOS $true -Notes 'External Switch'}
$VM_Switch = "Internal Virtual Switch" # (Get-VMSwitch -SwitchType External).Name

# Create a new Virtual Hard Disk using 1MB Block Size as per Microsoft's Recommendations
# https://technet.microsoft.com/en-us/library/dn720239.aspx

New-VHD -Path $VM_DiskPath\$VM_Name.vhdx -SizeBytes $VM_DiskSize –Dynamic –BlockSizeBytes 1MB 

# Create a new Virtual Machine

New-VM -Name $VM_Name -Generation 2 -MemoryStartupBytes $VM_MemorySize -VHDPath $VM_DiskPath\$VM_Name.vhdx -SwitchName $VM_Switch
Set-VM -VMName $VM_Name -ProcessorCount $VM_ProcessorCores -StaticMemory -Notes "$VM_Name`r`nCreated:`t$((Get-Date).ToString())`r`nSource:`t$(Split-Path $VM_ISO -Leaf)"

# Add a virtual DVD device for the installation ISO

Add-VMDvdDrive -VMName $VM_Name -Path $VM_ISO

# Configure UEFI Firmware to disable "Secure Boot" and "Boot from DVD"

Set-VMFirmware -VMName $VM_Name -EnableSecureBoot Off -FirstBootDevice (Get-VMDvdDrive -VMName $VM_Name)

The only thing I haven't figured out a solution for is that the Xorg process is continually using a lot of CPU (I use xrdp to connect to the VM to get around the Hyper-v screen resolution issues).

  • It seems that VMs installed via your script have same issues that I described. [Xorg process is continually using a lot of CPU] - means that it used sofware graphics render instead hardware. Can you use dragndrop from/in host OS to guest OS?
    – AeroSun
    Commented Jun 9, 2019 at 22:58

So, I tried different distro and finally we have the followed situation:

  • Host OS - Windows10x64 1809
  • Any linux distro works on Hyper-V only with software graphics acceleration and it cant be change
  • MS tools for linux that should resolve this issue dont works - the guest OS just hung
  • Even ubuntu built-in distros in "fast creation" option dint works (that should work fine), it hung too.

So Windows10x64 1809 is bad choise for virtualization. The better way - is to use Win7x64 + vmware.


I created a Hyper-V VM for Linux Mint like this:

  • Download the ISO file
  • Select New | Virtual Machine and configure as you prefer except for the generation where you should choose Generation 2
  • After completing the wizard, choose Settings for your new VM and in Security turn off Secure Boot.

Now you should be all set.

Note: I don't know why, but when I first tried to run the virtual machine, it seemed to hang so I turned it off and restarted it and it booted up fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .