0

I purchased some used hardware for CCNA/CCNP purposes, and I have a router that has a corrupted Cisco IOS. I have 2 other routers that have a good file. I'm trying to figure out the best way to transfer that file w/out a USB drive, partially because I want to practice doing so w/out a USB drive, and partially because the apparent requirements for a USB stick for Cisco are <1GB and FAT32, none of which I have (I assume they can be purchased if needed).

If I don't know the IP information of the broken router (having never been into the IOS), is it possible to set up a tftp session to one of my working routers via crossover cable and pull the image over that way? The dialogue for that seems to indicate that I need to know the IP info for the broken router. Are there other options?

Update (5/23): I've attempted to load via USB Flash after finding a really old flash drive sitting in a box, and now have a different issue in that the router errors out while loading the file from the USB drive:

rommon 5 > boot usbflash0:c1841-spservicesk9-mz.124-3a.bin
program load complete, entry point: 0x8000f000, size: 0x3d180

loadprog: bad file magic number:      0x0
boot: cannot load "usbflash0:c1841-spservicesk9-mz.124-3a.bin"

Thanks

  • Couldn't you use a large flash drive with a small FAT32 partition? – I say Reinstate Monica May 22 '19 at 19:18
  • I tried that, but the router didn't seem to like it. Was using MiniTool Partition Wizard. – Ender28 May 22 '19 at 19:53
  • Here's what I got when I tried to use a 7.5GB SAN Disk USB, 2 partitions *May 22 21:18:48.115: %USB_HOST_STACK-6-USB_DEVICE_CONNECTED: A Full speed USB device has been inserted in port 0. *May 22 21:18:48.755: %USBFLASH-5-CHANGE: usbflash0 has been inserted! *May 22 21:18:53.239: %USB_HOST_STACK-6-USB_FLASH_READY_TEST_TIME: USB flash 'Ready' test time over 4 seconds. *May 22 21:18:53.239: %USB_HOST_STACK-3-USB_FLASH_READY_TEST_FAILED: USB flash failed to pass 'Ready' test. *May 22 21:18:53.239: %USBFLASH-3-DEVSTARTSTOP: usbflash0 MSCD_StartStop failure in usbflash_mscd_scsi_listener! – Ender28 May 22 '19 at 19:58
  • I would suggest trying with only a single 256MB partition – I say Reinstate Monica May 22 '19 at 20:27
  • OK, tried that. Split to 256MB, deleted the second partition (7.2GB), and converted the remaining to FAT16 (as it turns out, I was wrong about FAT32). Still doesn't like it (same error as initial). I'm not sure why, every tutorial out there says that it should recognize it as long as it's formatted correctly – Ender28 May 22 '19 at 20:33
0

After a great deal of troubleshooting, I've come to the conclusion that there's a hardware issue on the router based on the fact that if the CF card of the non-working router is inserted into a working router, the image loads.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.