2

I have a desktop PC and a laptop both at home, and I'd like to remote into the desktop from my laptop. Both are running Windows 10, and for both I used my Microsoft account to create a user profile. The laptop uses the same password as my Microsoft account, but the desktop does not.

When I plug in the computer name and my credentials to remote in from the laptop, I am denied using both passwords. RD can recognize the desktop on the network since it asks for credentials, but won't let me in. The auto-populated used account for remoting in is MicrosoftAccount\username@host.com. Neither my Windows account password or Microsoft account password work for this. I've also tried DESKTOPNAME\username@host.com, no luck there either. What is the proper way to authenticate from remote desktop here?

1
  • Try to use the same Microsoft account password for both? Also clean out the old credential using Control Panel > User Accounts > Manage your credentials.
    – harrymc
    May 23, 2019 at 5:52

2 Answers 2

3

I just had this exact issue, possible as I signed in using the authenticator app, I changed my user on host pc to a local account, then signed back into MS account using password not authenticator app, then the RDP accepts MS Acc email + password to connect.

1
  • Thanks, I had the same issue with the authentication. This should be marked as the correct anwser.
    – Daniel
    Sep 2, 2020 at 7:56
0

I had the same problem and what I understood is that you are required to login at least once with your MS account password to activate RDP access with the password. This is what I did with my Windows 10 21H1. Moreover, I also had the "passwordless" sign in option active in my MS account options, and I had to deactivate it and set up a password, and then I had to sign in to my laptop with that password for the RDP to work. Later on, even if you login with a PIN, RDP will continue to work with the password, not with your PIN.

Remember that for the account to work with RDP, it has to be an Administrator account or that it's added to Remote Desktop Users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.