I installed Thunderbid as a snap today (Ubuntu budgie 18.04 LTS). I followed the instructions here to move my profile. This doesn't work. I copied the folder, but nothing is recognized in Thunderbird.

So, I tried:

  • Going to 'troubleshoot information' and clicked the button that said "Open Directory". This does not do anything.
  • I then ran Thunderbird from the command line, and did the same thing again, which shows 'env: ‘/snap/bin/code’: No such file or directory when I tried to open the profile folder. I checked this folder. The folder /snap/bin exists and contains a file called 'code' which is a shared lib file, with a target of /usr/bin/snap, and has all permissions (lrwxrwxrwx). Don't know what to do with that information tough.
  • Then I tried importing the files via 'events and tasks --> Import'. When I get to the dialog, I can't access my USB, altough permissions on it should be sufficient (I ran chmod 775 on it)
  • I tried re-installing Thunderbird, but ended up with the same problem.

Does anyone know how to solve this? Thanks!

1 Answer 1


Okay, seems that the bigger problem was not thunderbird being unable to open the profile location (still not working), but me not following the instructions correctly.

What I did:

  • Followed the instructions here, and ran thunderbird -ProfileManager from command line to create a new profile. The manager also showed me the location of the thunderbird profile when installed as a snap on ubuntu: /home/yourusername/snap/thunderbird/common/.thunderbird/xxxxxxxx.profileName
  • Closed Profile Manager and thunderbird instance
  • Replaced the contents of the new profile folder (on the shown location) with the contents of the exported one.
  • Started Thunderbird again --> Everything works now!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .