My Ctrl+C key-combo seems to have abruptly stopped working globally on all programmes. All other cut/paste/select-all/undo/redo/formatting combos are working.

Using online keyboard testers, the following result is seen:

  • Ctrl key works / lights up when pressed
  • 'C' key works / lights up when pressed
  • If I press Ctrl + 'any other letter' - both Ctrl and the other letter key lights up on the tester, showing that both work.
  • However, if I press Ctrl + C, then Ctrl key lights up on the tester, but not the 'C' key.

Given the above result, I tried switching on Sticky keys, and the Copy shortcut works with sticky keys (i.e. I press Ctrl, release, and then press C)

I've tried reinstalling my keyboard drivers already as well.

I have read through these two questions - THIS and THIS however, the solutions provided there have not worked. I am completely stumped at this weird behaviour. Would appreciate some expert help on this, including how to further test in order to pinpoint the possible problem.

  • Has this happened recently? If yes, you might rollback to a previous system restore point. But have you installed or updated any product since then?
    – harrymc
    Commented May 25, 2019 at 15:17
  • Thanks, guys. System restore was a last option because I had a heavy game download done that I didn't want to lose (never ran or set up the game). Anyway, after 2 days of trying a lot of different things, my copy keycombo has started working on its own within 3 hours of me offering the bounty, without any changes done :| Still no idea what went wrong, but it is working now. Thanks. Let me know if I should just delete this question or not.
    – Shisa
    Commented May 26, 2019 at 11:10
  • Btw, the keys weren't working in safemode either, earlier.
    – Shisa
    Commented May 26, 2019 at 11:11
  • Deleting the post won't get you back the bounty. I advise to flag your post and ask a moderator to undo the bounty because the problem went away. Only delete the post some days afterward.
    – harrymc
    Commented May 26, 2019 at 17:46

2 Answers 2


My Ctrl-C combination stopped working today on all applications other than CMD Prompt. I downloaded the Passmark Keyboard Test app to help diagnose the problem. The Control key was recognised, the C key was recognised but the combination Ctrl-C was not. Ctrl-V was recognised as was all other dual key combinations. I tried everything to try to resolve this including installing different languages, reverting to a previous Windows state etc. Nothing worked. I then saw a post suggesting that the BIOS should be reset to default settings. I then recalled that earlier today my PC had booted into the BIOS for no apparent reason.

I booted into the BIOS, reset to default settings, remembering to set the disk access to AHCI before rebooting and, as if by magic, Ctrl-C now works as before. I hope this helps someone.


Usually this would be a case of (key) buffer overflow. I used to have similar problems, where all of a sudden, some keys would stop working.

A simple keyboard driver uninstall followed by a restart should fix it. If it doesn't work, just stop working and let your computer cool down. Check back 15 mins later. The heat might have been causing the problem somehow.

P.S: Please don't bang your PC. Treat it like a fragile lil baby :)

I'm not an expert on this, but this would be my best guess for a quick fix.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .