0

I am trying to run Spyder on my MacBook Air - it previously ran, but now when I click on it, I get nothing:

Previously, I did the following: -Created a new folder under Applications with name spyder.app -copied the executable from the anaconda3/bin directory into the contents of this folder -placed the "folder" in the dock

everything worked just fine.

I recently updated to OS 10.12.6, and nothing happens when I click on spyder. I updated anaconda, as well as spyder, and still nothing.

Trying this from the command shell gives the following:

192:Applications monty$ spyder


Traceback (most recent call last):
  File "/Users/monty/anaconda3/bin/spyder", line 7, in <module>
    from spyder.app.start import main
  File "/Users/monty/anaconda3/lib/python3.6/site-packages/spyder/app/start.py", line 35, in <module>
    from spyder.config.main import CONF
  File "/Users/monty/anaconda3/lib/python3.6/site-packages/spyder/config/main.py", line 22, in <module>
    from spyder.config.user import UserConfig
  File "/Users/monty/anaconda3/lib/python3.6/site-packages/spyder/config/user.py", line 26, in <module>
    from spyder.utils.programs import check_version
  File "/Users/monty/anaconda3/lib/python3.6/site-packages/spyder/utils/programs.py", line 18, in <module>
    import subprocess
  File "/Users/monty/anaconda3/lib/python3.6/subprocess.py", line 136, in <module>
    import _posixsubprocess
ImportError: dlopen(/Users/monty/anaconda3/lib/python3.6/lib-dynload/_posixsubprocess.cpython-36m-darwin.so, 2): Symbol not found: __Py_set_inheritable_async_safe
  Referenced from: /Users/monty/anaconda3/lib/python3.6/lib-dynload/_posixsubprocess.cpython-36m-darwin.so
  Expected in: flat namespace
 in /Users/monty/anaconda3/lib/python3.6/lib-dynload/_posixsubprocess.cpython-36m-darwin.so

Thanks for any help!

  • works fine on 10.13.6 – jmh Jun 6 at 23:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.