0

I use Toad (Quest Software) quite a bit, as well as SQL Developer and Crystal Reports.

In the past, I would copy text from Toad, which had color and is a mono-spaced font, to Word or Outlook, and the coloring and spacing would persist.

Since sometime in early April, my options for pasting to Microsoft applications are 'Keep Text Only (T)'. In Word, my paste settings are not messed up - the option is 'Keep Source Formatting'.

This works fine. I have paste options and can cut and paste html text from

  • Outlook to Word, Excel
  • Chrome to Word, Excel, Outlook
  • SQL Server code to Word, Outlook, (Excel has more options, but they are still just text)
  • Visual Studio code to Word, Outlook, (Excel has more options, but they are still just text)

Mixed results

  • SQL Developer to Outlook (has font, not color)

I can only paste text from

  • Toad to Word, Excel, Outlook
  • SQL Developer to Word, Excel
  • Crystal Reports to Word, Outlook, (Excel has more options, but they are still just text)

I just upgraded Toad from 13.0 to 13.1.1. I have Office 365 ProPlus version 1808, and I have an update for that scheduled for tonight. Since there are unrelated applications (Crystal, Toad) having the same issue pasting to Microsoft products, it seems like an Office or Windows issue.

This link Paste Special Option missing doesn't help, because it is too old. And while I have Skype, it's a newer version than this link is talking about, too. In case it is related, my Skype version is Skype for Business for Office 365 MSO (16.0.10730.20264) 32-bit.

My help desk has reinstalled office. Today we were looking at rebuilding my profile, but the problem existed for the profile for the help desk person too, so we did not.

Other than the Office upgrade, what else might be the problem? Where else do we look?

We have found one work-around. Paste the text to Notepad++ and change the language to SQL. Then under Plugins, choose NPPExport and Copy all formats to clipboard. Then, from there, I can paste to Word or other Office apps. That is several steps instead of just a simple copy/paste like I was doing. Like I'd like to do again.

  • One option is to set the desired formatting in Word, and then use Paste and Match Style. I'm not at a PC to confirm this will work, but give it a try. – Christopher Hostage May 23 '19 at 18:00
  • @ChristopherHostage Where is the Match Style option? When I paste, I only see the option to paste as Text only. I can set the font to a mono-spaced font first, but I still lose the coloring. – thursdaysgeek May 23 '19 at 18:10
  • I remember that phrasing from prior versions. Here's another thing to try : File->Options->Quick Access Toolbar. Scroll down, choose Paste Special and Add. OK out and make a new Word doc. Go to Toad and copy something with formatting. Go back to Word and click the Paste Special button on the top left. You'll get a list of potential formatting types. Perhaps one will have the result you want. I don't experience the issue, so sorry I can't effectively test. – Christopher Hostage May 23 '19 at 21:32
  • @ChristopherHostage You got my hopes up! Unfortunately, the options under Paste Special are 'Unformatted Text' and 'Unformatted Unicode Text'. Source is "Unknown', which seems like a clue. – thursdaysgeek May 23 '19 at 23:11
  • @ChristopherHostage I also found a 'Paste and Keep Source Formatting', so I added that. It's disabled. – thursdaysgeek May 23 '19 at 23:19
1

I had the same issue when using TOAD for Oracle v12.9.0.71. You have to change the settings in TOAD as well to be able to copy text in rich text format.

In TOAD, please go to (See attached image):

View => Toad Options => Editor => Behavior => Check the "Copy text in rich text format" option and click Apply.

The format/styling should persist when pasting into any MS app like Outlook/Office.

Note: By default, MS Word preserves the original formatting when you paste content into a document using CTRL+V. Details: Link

  • That was it! Also, thank you for giving the directions in text and not just an image - my company blocks imgur. – thursdaysgeek Jan 29 at 19:43
  • Ok, so that wasn't my entire question, but Toad is what I care about the most. – thursdaysgeek Jan 29 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.