2

After updating Chrome, I've noticed that when I enter the first letter of a commonly visited site like 't' for twitter, it no longer autocompletes to the twitter url, instead it is autocompleting a random google search result I've searched for once.

So even if I've visited a page thousands of times, it's still putting the google page as the first suggestion. It's not suggesting new search results, but terms i've previously searched for. But surely a URL I visit daily should rank above a google result I've only accessed once.

Is there any way I can fix this? I know how to manually delete individual autocomplete suggestions, but I don't want to have to keep doing this.

  • Are you sure your history or any history related data wasn't removed during the update? That could be the reason why – Sickest May 24 at 3:32
  • Try using your chrome for like 1 week and see if that doesn't readjust all your most commonly typed urls. Lastly if you visit a website daily/frequently. You should make it a bookmark. – Sickest May 24 at 3:34
2

It's a bug: https://bugs.chromium.org/p/chromium/issues/detail?id=962599

Work-around:

  • Go to: chrome://flags/
  • Search for Omnibox Google Drive Document suggestions
  • Disable Omnibox Google Drive Document suggestions
  • Relaunch chrome

Source: reddit

  • This worked! Thanks – Anthony May 28 at 8:26
  • @Anthony, Please mark this answer as correct by hitting the check mark. – Abram May 30 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.