0

I have an English version of Windows 10 operating system with Hungarian keyboard. The general use of non-Hungarian Latin special characters (and I guess this is the same of all the Latin keyboards) is the following: first the accent should be written, and then the base character should be pressed. For example, accent ˇ exists on my keyboard on key 2 with AltGr, so the Slavic č letter can be written as follows: AltGr+2, then release, and then press C. (When I want just the accent, I simply press space after the accent.) This works also with some other accents.

The problem is that it does not work with the following two special accents:

  • ~ (AltGr+1), so I cannot write for example the Spanish letter ñ
  • ` (AltGr+7), so I cannot write for example the French letter è (not to mixed up with é, which is a native character on my keyboard)

On my previous laptop it worked. Being relatively frequent characters, I guess there must be a setting which tells if these should be primarily treated as accents or direct characters, and I guess that just the default has been changed. Does anyone has any idea about how to set up or how to overcome the problem?

0

Here are two work-arounds:

  • Press Windows, type char and select *Character Map'. Use that application to enter any character in any font on your PC, copied into the clipboard.
  • N.B., note the keystroke shown at bottom of dialog, e.g. Alt+0241 for tilde-n, ñ.
  • In most windows applications, you can insert that character by pressing and holding Altand typing 0241 using the numeric keypad (not the numner keys above the letters).

Character Map

Admittedly, this is not as convenient as using a dead key combination, such as Ctrl~n, which serves as a mnemonic instead of enigmatic `02411 for the ANSI value.

  • Thanks for answering! It is interesting what you wrote, but indeed did not answer my question (why ˇ or ´ works differently than ~ or `).Regarding to the certain example: for the letter ñ I have no keystroke, and at me the Alt + 0241 is ń, and not ñ. – Csaba Faragó May 25 at 19:36
0

The reason this is not working for you is because the keyboard layout you have selected does not support it.

In order to make your keyboard support it, plus most language characters, change (or add) English -> United States International as a keyboard layout. This way, all the keys you say work, and others too.

For example AltGr + 5 = €, AltGr + c = ©, AltGr + l = ø, AltGr+w = å and of course ' + c = ç and ~+n = ñ.

  • Thanks for your suggestion. Indeed, I have US keyboard layout as well (and I could install Spanish or French, of course); indeed my real question is why accents ˇ and ´ work different than ` and ~. – Csaba Faragó May 25 at 19:44
  • A keyboard layout simply defines what characters are present for a keyboard. Even though you may be able to type them, the keyboard layout is a driver that converts the keystrokes into actual keypresses, and AltGr and combining chars to form another is handled by the keyboard driver. So if your layout does not offer this, it simply doesn't work or works differently. – LPChip May 25 at 22:23
0

Install AutoHotKey and put the desired characters to letters still unused with AltGr key.

<^>!e::è    ; AltGr + e produces è
<^>!e::ñ    ; AltGr + r produces ñ

This way, you can type them in similar way as you type [ or {. I am doing this and it works nicely.

UPDATE:

If you do not want to occupy limited slots of your AltGr shortcut space, consider this alternative which has almost unlimited namespace:

:*:§e\::è    ; typing §e\ e produces è
:*:§n~::ñ    ; typing §n~ e produces ñ

This is especially considerable of the Hungarian keyboard. I tested it on my Slovak keyboard which is very similar and it works nicely. Let me explain the sequence, which is easy to remember:

  • it starts with § what means we want to type a special character
  • second character is the base character we want to type (e or n)
  • third character indicates character modifier (\for ˋ, ~ for ˜, v for ˇ ...you get the idea) so č will be §cv

Based on the above schematics you can define many characters you need.

  • I believe your keyboard layout actually has to have the keys in order for this to work, because it will have to "type" the key, so I don't think this will work for him, but I could be mistaken. – LPChip May 24 at 21:25
  • @LPChip – I have Slovak keyboard layout which is very similar to Hungarian in many aspects and I am successfully using this. I checked Hungarian layout for unoccupied AltGr combinations before suggesting them above. So I think it will work. – miroxlav May 24 at 21:27
  • ah ok. :) good to hear this workaround works then. – LPChip May 24 at 21:30
  • Thanks for suggesting. I'll use it when I needed these characters intensively; now I am just curious why accents ˇ or ´ work different than ~ or `. – Csaba Faragó May 25 at 19:42
  • @CsabaFaragó – in which program are you attempting to write that character? – miroxlav May 27 at 19:07
0

Your confusion seems to be that diacritics are always typed the same way. It's not like that. Different languages type differently, different keyboard layouts type differently

The general use of non-Hungarian Latin special characters (and I guess this is the same of all the Latin keyboards) is the following: first the accent should be written, and then the base character should be pressed.

If the diacritic is typed before the character then it's called a dead key, because in real typewriters that key doesn't move the cursor which means what was typed will be combined with the base letter later. However some languages doesn't use dead keys at all. For example in the standard Vietnamese keyboard layout (which no one uses) all the diacritics are type after the base letter, producing a combining character. Vietnamese people actually use the US layout with an IME and type the diacritic according to some rules after the base letter and the sequence will be transformed to the correct word by the IME

Many other languages' keyboards have specific keys for the accented letters, so they don't use dead keys either. For example French keyboard have a dedicated key for é, è, à... so they just press those keys directly without any ` ́ accents

Some keyboard layouts use the AltGr key to produce accented letters instead. The international US layout uses just AltGr without any dead keys. Some other layouts use both dead keys and AltGr keys

AltGr generally produces the whole key, not dead key, so if ~ and ` are typed by AltGr in your layout then you can't use it to make accented letters. If there are ñ or è in any AltGr combination then you can use it, otherwise you have to use other ways to type those letters

  • One of the ways is to use Alt codes. This is useful if you don't type that character frequently. Just enable hex numpad and press Alt+++code
  • Another way is to create a keyboard layout for your own using Microsoft Keyboard Layout Creator. This way you can also remove unused keys or reorder keys to make typing more efficient. For example you can load the Hungarian layout and add dead keys for French/Spanish and now you can type multiple languages at once without changing layout. You can use any combination of dead keys and/or AltGr keys to type any Unicode characters

Of course AutoHotkey is also a solution

See also

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.