1

I'm getting this error every 5 minutes on one of my Linux servers. The name in this case is not a hostname, but the workgroup-name I have set in the smb.conf file of both servers. I have no idea why it keeps doing this, the only thought I have (as a Windows admin) is that the second server is trying to become the master-browser or something and upon resolving the workgroup name gets a reply front the first server that was turned on. Which would explain why the other server shows no errors in its log.

Both systems have statically configured IP's and resolv.conf containing both domain and nameserver entries.

It makes me wonder though: since it is nmbd that's doing this, do I still really need it in a SMB3.1 Win10 network? Or can we never get rid of NETBIOS?

1

It makes me wonder though: since it is nmbd that's doing this, do I still really need it in a SMB3.1 Win10 network? Or can we never get rid of NETBIOS?

nmbd's functions (browsing and NBNS) have always been optional for modern clients (Win2000+). The last system which deliberately sent a NetBIOS datagram query before the actual SMB connection was Windows 98 (or perhaps Windows ME).

So you can connect to the smbd service by IP address (or DNS name) and speak whatever SMB/CIFS version you like, whether it's SMBv1 over NetBIOS Session over port 139, or whether it's SMBv3.1 over raw TCP over port 445, without having nmbd running.

| improve this answer | |
  • As a primarily Windows admin, I'm often confronted with the fact that even with Windows 10 I must still open up the NETBIOS ports to access file shares. I guess if I only access my smb-shares using a FQDN, it should not have to use NB. The fewer services I need running, the better anyways. I'll try and disable nmbd for a while and see if I run into weird problems.. – Mark May 26 '19 at 10:52
  • As long as you have any alternative method of resolving the name (raw IP address, /etc/hosts, DNS, mDNS, LLMNR) you should be fine with only having smbd and only port 445/tcp. (SMBv2+ isn't supposed to even use 139/tcp.) – user1686 May 26 '19 at 13:23
0

Multiple responses could be received because of a host in the same physical network which has two interfaces. The broadcast query is then replied to both of them by your nmbd. See this 17 years old post: query_name_response: Multiple responses received.

Check also the file smb.conf regarding the interfaces parameter, if it doesn't list more than one interface.

| improve this answer | |
  • I already checked, but systems have only a single interface. For that reason, I have not set the interface-property in smb.conf. The confusing part is that the name that is referred to in the error is the name of the workgroup and not either system's hostname. – Mark May 26 '19 at 10:50
0

For me, the answer was to be found here: https://forums.freebsd.org/threads/samba-multiple-2-responses-two-freebsd-systems-on-my-network.65759/
And specifically the last sentence

If you are doing standalone, then you should have local master = no, domain master = no and preferred master = no. Disable all the wins stuff too. I think all you would need is workgroup = WORKGROUP

However, I don't use an NT domain to log on to. I actually use nothing more than a workgroup. the "prefered master = no" was the one I had to change. I had it set to 'yes' on 1 host. Changed to 'no' and restarted samba. Everything kept working after that and the messages stopped.

| improve this answer | |
0

Add/update the following lines in smb.conf in the [global] section:

[global]
bind interfaces only = yes
interfaces = 127.0.0.0/8 eth0  # -> subnet where samba serwer is
smb ports = 139
prefered master = yes

Next, restart the NetBIOS server part of Samba:

sudo systemctl restart nmbd
sudo systemctl status nmbd

You should see in the log files after the restart:

Samba name server "xxx" is now a local master browser for workgroup WORKGROUP on subnet "IP server Samba"

After that, the mentioned messages should stop.

| improve this answer | |
  • Hi @rol. Welcome to Superuser and thanks for taking the effort to answer this question. I edited your answer (mainly formatting; some text/grammar improvements) for clarity. I hope you consent. In your answer, you provide a solution, but no explanation. Could you elaborate (for the original poster) why this solves the problem? That would really improve the quality of your answer. Thanks! – agtoever Nov 15 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.