6

We use a simple backup system at work: Every day we connect an external USB harddisk to our Ubuntu Linux server, which then calls a backup script (cronjob) at night to perform all the backup. Next day we disconnect the USB harddisk, and plug in another one. So we always have two harddisks with backups.

This has worked fine for over a decade with various harddisks from different manufacturers.

But recently we bought a Toshiba Canvio 2TB harddisk, and ever since I've struggled with insanely slow speeds. (Like 1,5 mbps). When searching for this problem I find a ton of posts on various forums from people struggling with the same thing. And there are many suggestions about what to try - but none of them makes any difference whatsoever.

This Toshiba Harddisk takes 66 minutes to copy 10 gb from a folder. Our other harddisk does the same job in just a single minute. But when connected to a Windows PC, the Toshiba harddisk seems to be working fine with fast speeds. So it's a Linux thing apparently.

The backup script uses wget to get files from FTP sites, from both LAN and WAN. A full backup takes about 5 hours (on a good harddisk).

Here is a list of things I've tried so far:

  • I checked and confirmed that the cable is actually connected to a USB3.0 port of course (which shouldn't matter though since the other harddisk using the same port and the same cable works just fine and fast)
  • I tried another Toshiba Canvio harddisk, different sub-model - was also incredibly slow.
  • I tried setting /proc/sys/vm/dirty_bytes and dirty_background_bytes
  • I tried setting /proc/sys/vm/swappiness to 1
  • I've tried setting --limit-rate on wget to different values, like 20m and 50m
  • I've tried formatting to different filesystems, like ext4
  • I also tried both gpt and msdos - not that it should matter

Those are all suggestions I've found on various sites during the past week, but none of them makes any difference in my case whatsoever.

At this point I'm extremely curious to learn why this is happening. What is it with these Toshiba harddisks that Linux doesn't like? In other words: What should I look for when buying harddisks to avoid this in the future?

Thanks!

  • 1
    "What should I look for when buying harddisks to avoid this in the future?" It sounds like look for "Toshiba Canvio" and if you see it, buy something different. :-) – fixer1234 May 26 at 5:27
  • 2
    For some time now a have a similar problem, where I/O througput gets very low, the I/O processes stay in D mode for a long time, and dropping buffers with echo 3 | sudo tee /proc/sys/vm/drop_caches at least temporarily fixes the problem. Possibly that also helps in your case, possibly not. I don't have an explanation. Verify by monitoring I/O throughput with iostat in a loop, or dstat etc. – dirkt May 26 at 7:04
  • Looks like it falls back to USB 1.1 mode. Anything in the logs when connecting the disk? What kernel version are you using? – xenoid May 26 at 11:07
  • lsusb says Bus 002 Device 002: ID 0480:0800 Toshiba America Inc, which (afaik) means USB3.0 device connected to USB3.0 port. I'm still searching for this, and currently suspects it has to do with SMR drives. Shingled Magnetic Recording. It appears Linux just has a problem with SMR drives. – mr_lou May 26 at 11:27
  • 1
    @mr_lou If I connect an USB3 disk to my laptop /var/log/syslog reports: "new SuperSpeed USB device number 2 using xhci_hcd". "Superspeed" is USB3... So logs tell you if the disk is identified as an USB 1/2/3 device. They also tell you if it is handled by the XHCI driver. – xenoid May 26 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.