I have a Windows XP Pentium III desktop with two hard drives. The first one has the OS and is luckily working. The second drive on the secondary master IDE channel few days back was unable to read some files and since then for some time it was failing and reviving intermittently and now it is always showing as failed on the IDE channel

When the HD was intermittenly failing, I was able to copy some data from it to the other drive - also during that time if the system was running and the hard disk failed at that time, the system froze and then i had to reboot.

then I got a new 80 gb hdd similar (same make - seagate barracuda) to the earlier failing one, a new data cable for the drive and an IDE to USB adapter.

the new hard drive i installed in the previous drive's place (secondary master), formatted it and it worked for 1 day and then it also failed - simultaneously i connected the old hd to the IDE/USB adapter and i could view all the data - some of that data i was able to back up from the old hd to the new hd before the new hd failed

the new hd i have tried connecting on the primary channel as the slave disk but when i do that then the bios does not detect either the OS drive or the new drive and the system does not boot

surprisingly, the older (previously failed) hd and the new hd are both working fine on the usb channel with the IDE/USB adapter.

i have ruled out any problem with the secondary channel since the dvd rom i was earlier using as primary slave have now connected to secondary master and it works fine.

i am really confused by this behavior on my system. please can anybody try to solve this for me. thanks.

  • How a IDE controller deals with an optical drive is different than a hard drive, the controller is defective.
    – Moab
    Jan 14, 2011 at 15:47

4 Answers 4


First - back up whatever data you can get off the drive - any way you can get it (USB?).

Then there are a couple of things to look at. Cables. First - check loose connections. That's easy to wreck if you're changing hardware. Second - Check for cable failure. Older hard drives can be picky about using new IDE cables (the ones with twice as many smaller diameter wires and USUALLY one of the end connectors is a blue). Experiment with using both old style and new style cables, and if possible use something other than the one that has been in the box while it's failing. You didn't specify model of your drive so I can't say if you need the "Enhanced" or "Non-Enhanced" cable.

Your "new" 80 GB HD is probably 6-10 years old so you need some assurance that it's working. If you like to play with old hardware you'll need something like SpinRite 6 http://en.wikipedia.org/wiki/Spinrite (or similar) to verify the disk is working properly. I often use SpinRite (booted from USB thumbdrive) to check old drives in a USB enclosure attached to a relatively new system that I KNOW is working.

You may also need to let your BIOS "find" the new hard drive. Varies by BIOS how this is done but if it's not on "AUTOMATIC" then the BIOS may need to "discover" the HEAD/SECTOR etc for your new drive - unless it's identical to previous one of course.


If it's not the cable failure, then it sounds like the drive controller. Remember - the cable is cheapest to replace, so replace it first.


I'll show my age here providing the correct answer to this ancient post, but I'm surprised to see that no one mentioned the master/slave/cable select jumpers on the IDE drives. Only one drive on the IDE chain can be jumpered as master and only one can be jumpered as slave. If the drive is jumpered for cable select than it's role is determined by it's position on the cable. The USB adapter doesn't care about this as there is only one drive connected to it, but the IDE controller will NOT be happy about a failure to adhere to this rule. SATA is so much simpler.

Further reading: http://www.pchell.com/hardware/masterslaveorcableselect.shtml


It could be either 1)the IDE Cable 2)the hard disk controller 3)the power cable from Power supply to HDD 4)the power supply itself 5)the motherboard ata Port

You must log in to answer this question.