1

tldr; When I reset my Google Chrome theme to default, and restart my browser, the title/tab bars take on a dark theme and I can't figure out why. I think there is some kind of hidden settings/profile location I can't find

I'm on macOS Mojave 10.14.5, using Google Chrome latest (currently Version 74.0.3729.169 (Official Build) (64-bit)) and I'm having an issue where, for my main user profile, no matter what I do I can't seem to reset Chrome to it's default theme/styling. It always appears as a dark titlebar & tabs

I'm not running macOS dark mode at all (for Chrome, or by default). I'm looking for some other suggestions on what I can do to get the titlebar to display "normal" again (light mode), because I've tried everything I can think of.

My title bar shows up as below:

My titlebar color

The default, however, is supposed to show up as below:

Default titlebar color

I can can get my titlebar to show up like it's supposed to, by doing:

  • Going to the theme store & installing a theme
  • Going into Chrome settings, and choosing "Reset theme"

However, this only persists until the next time I restart Google Chrome.

This only occurs on my personal laptop, it doesn't occur on other computers I'm using that I've synced my Google Preferences to.

Other things I've tried:

  • Signing out of my Google Chrome sync
  • Completely deleting & reinstalling Google Chrome and attempting to delete all of the related preferences & settings files
    • And everything chrome-related in ~/Library/Preferences
  • Toggling macOS dark mode off & on again
  • Using defaults write com.google.Chrome NSRequiresAquaSystemAppearance -bool Yes (and trying it w/ No & resetting to default)
  • Deleting the folder with all the Google Apps
  • Using the "reset settings to their original defaults" setting in Chrome
  • Deleting ~/Library/Preferences/com.google.Chrome.plist
  • Deleting ~/Library/WebKit/com.google.Chrome
  • Deleting Chrome with AppCleaner (which found some referenced folders in /var/ and other locations)
  • Disabling GPU acceleration
  • Deleting everything Google related from all locations in all the directories noted here
  • Creating a new Chrome profile
  • Resetting all chrome://flags to default
  • Trying Google Chrome Canary (it also inherits this dark theme/style)
  • Disabling dark mode on mobile Chrome (even though this shouldn't matter, because I've tried disabling sync previously, and deleting & reinstalling chrome and all associated folders I can find while disconnected from the internet)
  • Running the cleaning & optimization scripts via Onyx
  • Running the cleaning & optimization scripts from Clean My Mac. Deleting using the Clean My Mac uninstaller
  • Resetting settings under advanced option in Google Chrome
  • Restarting Chrome & rebooting my computer after trying all of the above

I created another profile on this computer, logged in, and started Google Chrome and it worked as expected/desired (light tabs). For the life of me, I can't figure out what I may have missed on my profile that could be interfering with the title bar/tab color.

I've also tried toggling dark mode while Chrome is open; the theme changes between modes but it still has a dark looking theme when in light mode (per the screenshot above). It's like there's a theme persisted that I can't rid of

I'v found a workaround (using a theme that mirrors the default) but at this point I'm interested in determining the root cause, without completely nuking my profile.

I'm at a loss of what the cause could be so any other suggestions on how I can troubleshoot or triage are appreciated.

  • It seems like the latest Chrome follows the system theme color, but something went wrong in your case. Try to: set the system theme to dark, start and stop Chrome, and then set to light, to see if this makes a difference. In the worst case, uninstall Chrome, scrub its folders, and reinstall from scratch. – harrymc May 31 at 6:31
  • @harrymc Thanks for the suggestion, I just tried the system theme change with no luck. I've uninstalled & scrubbed the folders a number of times (everything that I can find). There's something, somewhere, I'm missing... – Jay Dorsey May 31 at 16:39
  • When you scrubbed the folders. Which folders did you scrub exactly? – Niall Jones Jun 4 at 8:15
  • @NiallJones ~/Library/Application Support/Google, /Library/Application Support/Google, ~/Library/Preferences (and anything w/ google in name), the /var folders that weren't secured/protected and suggested by AppCleaner, /Applications/Google Chrome (the full app). I also looked in /Library/{PreferencePanes,LaunchAgents,LaunchDaemons} folders, and those same ones under my $HOME. I also deleted any *.plist files that had google or Google in the name in /Library or ~/Library subfolders. ~/Library/Caches/Google. – Jay Dorsey Jun 4 at 17:59
  • This is still not working after numerous attempts. I've settled for using the default light theme but I'd still like to identify the root cause. I think I'm overlooking a folder/setting/configuration somewhere – Jay Dorsey Jul 3 at 0:23
0

How about a reinstall of the chrome app? Backup/Sync your logins and bookmarks before you do that.

Should be a piece of cake.

  • 1
    Thanks for the suggestion. I wasn't explicit in my post (I said "completly deleting Google Chrome") but I did try a complete removal/install numerous time (tried w/ syncing, without syncing, and rebooting in between) – Jay Dorsey May 31 at 16:07
  • Don't sync your themes with your google account then. Your profile will remain safe. For now I suggest you let the theme be as it is. Just blend with it until google rolls out a fix for it ;) – chillybones May 31 at 21:21
  • It may not be clear from my response, but the "delete everything Google related from my computer" covered this step. I've gone so far as to disconnect from wifi, delete everything.manually, rebooting, and reinstalling Google Chrome (no syncing) – Jay Dorsey Jun 1 at 1:42
0

This seems to be a problem introduces by a recent Chrome update. It will hopefully be fixed in some future version, but until then your options are limited to using a theme that has the color you like (not counting the non-recommended option of downgrading Chrome).

You may construct such a theme yourself or use one of the following:

In response to the poster asking for links, here are some links for this same problem, all dating from February 2019 or later, although without any real solution except theme change:

  • Do you have a link to the issue? The only other reports of this issue I can find are either resolved by disabling dark mode or Win10 related and not relevant – Jay Dorsey Jun 1 at 1:44
  • I have added some links to my answer. – harrymc Jun 1 at 5:46
  • 1
    Thanks, those are good, but 2 of them are for Windows and the Mac question has a marked solution/answer that's basically "turn off dark mode" (which I don't have on). The closest problem is probably this one and there's no solution for it yet, or possibly this one which also suggests dark mode (which the OP hasn't confirmed as a solution) – Jay Dorsey Jun 2 at 2:18
  • The problem was introduced this year and is probably an unintended side-effect, in other words a bug and not a feature, so cannot be solved by one of the traditional methods. The real solution is for Chrome to be fixed, but maybe some workaround will be found. You could test one of the themes said to fix it. – harrymc Jun 2 at 5:49
0

First, try changing your theme to another one available in the chrome web store. And then reset that them to default(this hard worked for me.

If this does not help navigate to "Restore Settings to Their Original Defaults" which should be under advanced.

  • Thanks for the suggestion. The new theme + reset works, but doesn't persist if I restart Chrome. I'm really most interested in finding the root cause of this. i do have 2 workarounds that are temporary (the new theme + reset & theres a theme someone published that is the same as the default) I didn't list that I'd tried resetting to original defaults but I think I did, so I'll try it again and see what happens. – Jay Dorsey Jun 3 at 12:37
  • Confirmed, this doesn't work either (even after a Chrome restart or a Chrome reboot) – Jay Dorsey Jun 3 at 15:17
  • It sounds like you have a file somewhere that's read-only since it keeps reverting. – Niall Jones Jun 5 at 14:14
  • @NiallJones Possibly? I haven't checked permissions on every file I've deleted, but I'm deleting with rm -rf and doing a restart afterwards. I'm not doing anything crazy, permission-wise with my system. It's a default install of Chrome via their installer (not homebrew) – Jay Dorsey Jun 7 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.