0

Can you help me recover my files that become suddenly 0-byte sized? I haven't done any operation on this disc partition (my OS is on another partition), so I guess theoretically the contents of the files before this problem happened are always there. I guess each of the now empty files are pointing to the starting memory block of themselves before the problem occurred. Do you think there is any hope to get them back ?

Full story:

I have Windows 7 on my computer. I had a large number of files an folders that I wanted to copy (approximately 14 GB) to my external Hard drive. I used SuperCopier at first but there was an error on nearly every transfer that says "The supplied user buffer is not valid for the requested operation". I googled it, but there was no clear quick answer so I deactivated SuperCopier and retried normally, the coping went smoothly until I discovered that nearly all the files are of 0-byte size both in the source and destination (I think the files with this problem are the same where the errors occurred). I am not sure, but I think the problem in the source occurred first during the first coping attempt and then when I copied them to the external HDD the problem was already there.

I looked on the internet it was suggested that it may be a virus but I don't think so as I pay attention to that and the files were fine before the first coping try. I ran on a command prompt chkdsk /f D: procedure, but it doesn't detect any problem. I tried some utilities on the internet but no hope. Even with a recovery utility, it would be of not much use if I lose file names or folder hierarchy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.