2

Summary:

  • I'm not being able to execute the Android Emulator or even the Nox App Player.
  • I think that there could be a problem with adb or I could be missing something.

After 3 days of trying to find something like a solution or thread with no success, I decided to come here.

First, I want to say a few things:

  1. I've just reinstalled my Windows (Windows 10 Pro) from 0, I mean downloaded a Windows 10 ISO, booted a USB and etc because It had no more disk space and I didn't know where the "trash" files that were consuming the space could be located [I had to reinstall Windows from scratch because Restart PC option at Windows Settings didn't work].
  2. I've installed the pertinent Drivers of my PC, after that, I decided to start installing Git, GitHub, Android Studio, JDK, Nox, Sublime Text, Steam, IntelliJ IDEA, etc. All this (Drivers and programs) downloaded from their respective sites, and not by using previous files.
  3. I went to Windows and Features, activated Virtual Hypervisor Platform as a thread of Android Studio specifies here as a requirement.
  4. I set up Android Studio and etc to start using it; Then I installed everything (SDK [I Don't know why but I had to manually create 2 new folders called "Android" and inside of it the "SDK" folder at AppData/Local/... so Android Studio could Download and Install the SDK folder content], Android x86 System Images: Irrelevant but: 5.0 and 7.0. after that I proceeded to install the Android Emulator at SDK Tools from Settings in Android Studio.

Said that I have to add that I had SVM in the BIOS activated before re-installing Windows, because before uninstall and re-install it I was being able to use Nox App Player (An 'Android Emulator') and any x86 Android System Image in my Android Studio.

I've tried by activating Hyper-V and deactivating it, or activating both Hyper-V and Virtual Hypervisor Platform but no matter what I keep getting the same error messages when I try to execute the Android Studio Emulator:

A little appointment: The timeline [1:47 - 1:48] looks like if it would take 1 minute between "errors" but the truth is that it was just coincidence, all was in like 3 seconds

1:47 PM * daemon not running; starting now at tcp:5037

1:47 PM * daemon started successfully

1:48 PM Emulator: C:\Users\Suegr\AppData\Local\Android\Sdk\emulator\qemu\windows-x86_64\qemu-system-i386.exe: WHPX: Failed to emulate MMIO access with EmulatorReturnStatus: 2 (InternalEmulationFailure )

1:48 PM Emulator: C:\Users\Suegr\AppData\Local\Android\Sdk\emulator\qemu\windows-x86_64\qemu-system-i386.exe: whpx_vcpu { emulator=000000003227ba30, window_registered=false, interruptable=true, tpr=0, apic_base=fee00900, interruption_pending=false }

1:48 PM Emulator: C:\Users\Suegr\AppData\Local\Android\Sdk\emulator\qemu\windows-x86_64\qemu-system-i386.exe: WHV_MEMORY_ACCESS_CONTEXT { Instruction={ size=16, bytes='A1 F0 00 E0 FE 80 CC 01 A3 F0 00 E0 FE C7 05 50 ' }, AccessInfo={ AccessType=0, GpaUnmapped=1, GvaValid=0, AsUINT32=4 }, Gpa=fee000f0, Gva=0 }

1:48 PM Emulator: C:\Users\Suegr\AppData\Local\Android\Sdk\emulator\qemu\windows-x86_64\qemu-system-i386.exe: WHPX: Failed to exec a virtual processor

1:48 PM Emulator: Warning: QObject::~QObject: Timers cannot be stopped from another thread ((null):0, (null))

1:48 PM Emulator: Process finished with exit code 3

I don't know If I'm missing something, something like... let's call it 'feature' that doesn't allow me to use emulators.

With "external" Android Emulators like Nox App Player, for example, I get the Blue Screen of Dead (BSoD)

Recently I've deactivated the SVM setting from the BIOS, and that allowed me to open and use Nox App Player. But as I said, before the re-install of Windows I was able to use everything without further problems, I had a BSOD problem with Nox App Player but just If I had Hyper-V activated while tried to execute it.

Relevant PC Specs I guess that it doesn't matter but the Windows 10 isn't OEM version (Original Equipment Manufacturers).

4
  • What build of Windows 10 did you install? It appears there is currently an issue with Android Studio on Windows 10 version 1903 if you use WHPX. The issue does not exist for intel HAXM. – Ramhound Jun 2 '19 at 4:28
  • It worth pointing out that in order to use WHPX, and thus Android Studio on a system with an AMD processor, Android Studio requires AMD-V to be enabled. AMD Secure Virtual Machine (SVM) does not exist on your particular hardware (or it should not since it was renamed to AMD-V). Additionally, Virtual Hypervisor Platform not Hyper-V is required if you have AMD hardware. It is worth pointing out your question is confusing. You have a lot of detail, most isn't about the error or Android Studio.\ – Ramhound Jun 2 '19 at 4:40
  • @Ramhound 10.0.18362 Build 18362. I haven't activated the Windows Insider Program yet. – Suegro LM Jun 2 '19 at 13:57
  • @Ramhound Yes, well I enclosed all that information because despite being usually irrelevant information, sometimes one of those attaches helps find a solution or the root of the problem, it is also this process that leads me to this situation. In my BIOS it says "SVM", probably I've to update it? I haven't done it since I bought it. Thank you for your feedback/comments/help – Suegro LM Jun 2 '19 at 14:15
3

Upgrading to Windows OS build 18890.1000 fixed the problem for me. AKA join Windows Insider fast ring.

Yes, I can confirm, that the Issue is fixed in the latest insider build 18890. But it is not fixed in the latest build of the 1903 update with build string 18362.86. I hope there will be a patch in the near future before the official release. It seems the developer team is on the right

WHPX Problem - Android Emulator

2
  • 1
    Please do not comment on downvotes within your answer body. You should either ask the reason you have received a downvote on meta.superuser.com or simply improve your answer. Commenting on the downvote typically just results in additional downvotes Additionally, if you are going to reference a link, best to quote the relevant from it. Based on that discussion it looks like there is a simply compatibility with Windows Hypervisor Platform (WHPX) 1903 issue with Android Studio. – Ramhound Jun 2 '19 at 4:23
  • I hadn't this problem the day before I formatted my PC, as I said, so I'm not that sure that the solution should be the Windows Insider, but thank you, I'll keep this as my last resort! – Suegro LM Jun 2 '19 at 14:34
2

This problem was fixed with cumulative update KB4505903. But at this moment you might have to install it manually via Settings > Update & Security > Windows Update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.