Immediately after starting a VM in VirtualBox, I receive a error box that contains the following error message:

Call to WHvSetupPartition failed: ERROR_SUCCESS (Last=0xc000000d/87) (VERR_NEM_VM_CREATE_FAILED).

I am running Windows 10 Professional, Version 1903 and have confirmed that Hyper-V is not enabled.

  • 1
    Are you running Windows 10 Professional?
    – Stevoisiak
    Commented Aug 6, 2019 at 15:38
  • I got the same problem and none of the solutions from here doesn't work for me. Could you please take a look on my question - superuser.com/questions/1508514/… Commented Dec 9, 2019 at 7:17
  • I don't have enough rep on this SE site to post this as an answer (perhaps someone else would though?), but I just managed to get my VMs to launch in VBox 6.2 on a Win10 Pro 1903 host with both "Hyper-V" and "Windows Hypervisor Platform" features installed: I just needed to update my VBox global config with VBoxManage setextradata global "VBoxInternal/NEM/UseRing0Runloop" 0. See this VBox forum post for details.
    – user293915
    Commented Jan 29, 2020 at 11:10
  • Minor correction to my previous comment (too late to edit it now): I meant in VirtualBox 6**.1**.2..
    – user293915
    Commented Jan 29, 2020 at 11:39
  • @ZaLiTHkA you could ask a new question and tick the "Answer your own question" box
    – aman207
    Commented Jan 29, 2020 at 14:26

8 Answers 8

  1. Open the "Turn Windows features on or off" settings (type optionalfeatures in the start menu or Win + R).
  2. Untick "Windows Sandbox" and "Hyper-V" .
  3. Restart windows twice.

This is a new feature in Windows 10 v1903 that uses Hyper-V on the backend (even if it's not enabled in Windows Features), which makes this feature not compatible with VirtualBox.

enter image description here enter image description here enter image description here

  • 4
    I am also facing this same issue. In my machine both hyper-v and sandbox not enabled (both are untick). Any other suggestions?
    – PSR
    Commented May 30, 2019 at 8:03
  • 4
    Two reboots are needed after disabling Windows Sandbox Commented Jul 13, 2019 at 2:13
  • 4
    In my case was unchecking "Windows Hypervisor Platform"
    – user63227
    Commented Jul 23, 2019 at 23:10
  • 7
    The "Windows Sandbox" can't appear for some people that are not using Windows 10 on english language (my case, I'm using Brazilian Portuguese). On that case, you can use the command line to disable it: Disable-WindowsOptionalFeature -FeatureName "Containers-DisposableClientVM" -Online
    – Dherik
    Commented Sep 13, 2019 at 17:44
  • 5
    I had to untick "Virtual Machine Platform" & reboot twice.
    – Nearoo
    Commented Jan 27, 2020 at 13:30

According to this VirtualBox forum post, there are several features which might use Microsoft Hyper-V, which is not compatible with VirtualBox:

Look in the "Control Panel" » "Programs and Features" » "Turn Windows features on or off", and make sure that the none of the following are active:

  • Application Guard
  • Credential Guard
  • Device Guard
  • <any> * Guard
  • Containers
  • Hyper-V
  • Virtual Machine Platform
  • Windows Hypervisor Platform
  • Windows Sandbox
  • Windows Subsystem for Linux (WSL)

If that doesn't work, enter the following command:

bcdedit /set hypervisorlaunchtype off

followed by a cold boot, i.e. shut down the computer, pull the power plug for 10 seconds, reboot.

For me, just disabling "Virtual Machine Platform" and restarting TWICE made it work.

WSL 1 will still work. I'm not so sure about WSL 2, which is currently available in the Windows Insider Program.

  • 4
    I can confirm that "Virtual Machine Platform" feature is required for WSL 2 Also mentioned here docs.microsoft.com/en-us/windows/wsl/wsl2-install Commented Jan 15, 2020 at 0:42
  • In my case, I had to uninstall Windows Defender Application Guard and reboot. Other solutions did not work. Commented Mar 7, 2020 at 19:22
  • Yep, I've just enabled "Virtual Machine Platform" to try WSL2 and VirtualBox broke. Disabling the component and restarting the notebook twice brought VirtualBox back to life again.
    – Alex Che
    Commented May 5, 2020 at 12:54
  • 1
    Virtual Machine Platform is he one that got me :)
    – Pepe Code
    Commented May 28, 2021 at 18:39

Finally solved the issue.

  1. Turn off Hyper-v
  2. Turn off Windows sandbox

by navigating to "Turn windows features on or off".

Restart the machine twice and then try to Start vm in virtualbox.

  • 9
    Restart twice EVEN if Windows sandbox was already off and only Hyper-v was turned off did the trick! Commented Sep 12, 2019 at 15:05
  • 1
    Also turn off "Containers"
    – nimrodm
    Commented Feb 19, 2020 at 14:14
  • Double reboots helped me!
    – Feanor
    Commented Apr 2, 2020 at 9:19
  • worked for me too! thank you, life saver!
    – petrosmm
    Commented Sep 18, 2020 at 19:38

In my case, turning Windows Sandbox and Hyper-V off and restarting my PC dozens of times didn't work. I even tried turning the features back on, then back off, then restarting another dozen times.

What did work, was disabling Memory integrity from Core isolation in Windows Security, possibly because it uses virtualization features, as do Hyper-V and the Windows Sandbox.

Windows Security screenshot

Now I can finally start my VMs again.

  • this worked for me
    – dipu
    Commented Jan 11, 2020 at 7:56
  • This also worked for me. Thanks!
    – Makotosan
    Commented Jan 17, 2020 at 4:55
  • I had this exact same problem, on a fresh windows 10 install, 21H1, with VirtualBox 6.0.4. The common fix of turning off windows features did not work. But this solution worked for me immediately. Thank you. Commented Jan 26, 2022 at 16:03
  • After trying the solution given by @aman207, THIS is what worked for me. I'm using VBox 6.0.14 running on Win10 pro compilation 19042 version 20H2 Commented Jun 20, 2022 at 16:51

I've gone through that same problem too and it was caused due to having an older version on my machine at that given time (version 6.0.22).

enter image description here

In order to solve it, I've gone to Virtual Box's download page, downloaded the version 6.1.16 for Windows hosts and installed this newer version

enter image description here

Then, as you can see in the next images, that error is gone

enter image description here

  • 1
    Surprisingly, this was exactly the solution for me - nothing else helped until I updated from 6.1.2 to 6.1.32 . I can't find the words to explain how I feel about the quality of error messages. Commented Mar 14, 2022 at 22:52
  • 1
    It is 2024, and ever since I did a big Windows update five months ago, my virtual machine wouldn't start. Today I installed the latest version of Virtual Box (7 something), and now it works again. Thank you!
    – Cerberus
    Commented Jan 16 at 4:44

Hyper-V needs to be disabled but not uninstalled. I wanted to maintain Hyper-V functions some of the time and have the option to reboot into windows with Hyper-V disabled.

I ran the following in an administrator powershell prompt:

bcdedit /copy {current} /d "Windows 10 no Hyper-V"

The entry was successfully copied to {95524711-fa90-11e9-b0c8-927c2d2c6eb6}.

Copy the GUID into the next command:

bcdedit /set "{95524711-fa90-11e9-b0c8-927c2d2c6eb6}" hypervisorlaunchtype off

The operation completed successfully.

Click restart while holding the shift button And keep holding shift

screenshot of restart

Select "Other Operating Systems" and your "No Hyper-V" option is in there.

boot menu Boot Options

If you want to change the default mode (either with hyper-v enabled or disabled), run msconfig and change the default on the boot tab.

msconfig screenshot

Thanks to Scott Hanselman for inspiring this post.


You don't need to disable Containers! Here's how to do it based on this article

VBoxManage setextradata "<VM Name>" "VBoxInternal/NEM/UseRing0Runloop" 0
  • While this helped with creation of the VM, I ran into the next problem later ("Attempting fall back to NEM")...
    – Eike
    Commented Nov 11, 2021 at 11:34

When Docker Desktop is running

When you currently do not need any docker container, that is running on your system, it is sufficient to close docker desktop by right clicking the icon in the right on your task bar:

docker desktop icon

Then select "Quit Docker Desktop" and the VM is supposed to run again. You can even restart Docker Desktop after that and relaunch your containers without breaking either the VM or containers.

(For sure not every functionality is guaranteed, but it's worth a test.)

Newer versions of Virtual Box are probably better in doing so (my post was created with VirtualBox 6.1)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .