I was trying to dual-boot ubuntu 18.04 using a bootable usb on my windows 10 pc. My pc uses uefi so made the usb into fat32 type. When I boot with my usb it shows alot of bugs like watchdog soft lockup cpu#x(x = some number). I am using acer nitro 5. Anyone know what this might be.

3 Answers 3


I googled alot and found a solution to this. You just have to go into the grub and press "E" while ubuntu is selected and then edit the file. On the line that starts with linux just replace quiet splash with noapic noacpi nosplash irqpoll . Hope this works. It worked quiet well for me. After installing ubuntu or while opening it you should go to the boot/grub/grub.cfg file and do the same thing there. Or else you would have to do the same thing everytime the pc starts up.

  • I've been searching for a solution to the soft lockup for a long time and the modeset was not the issue. This worked though, I believe it was related to the acpi management somehow not handling power to the cores properly. Thanks!
    – Rob
    Jan 27, 2020 at 16:21

Shutdown, boot from the computer, and immediately after the motherboard / computer manufacturer logo splash screen appears when the computer is booting, with BIOS, quickly press and hold the Shift key, which will bring up a GNU GRUB menu screen. With UEFI press (perhaps several times) the Esc key to get to the GNU GRUB menu screen. Sometimes the manufacturer's splash screen is a part of the Windows bootloader, so when you power up the machine it goes straight to the GNU GRUB menu screen, and then pressing Shift or Esc is unnecessary.

enter image description here

The Acer Nitro 5 has an NVIDIA GeForce GTX 1050 Ti GPU. When you are in the GRUB menu, press e to enter editing mode. This will bring up a GNU GRUB screen that looks like this:

enter image description here

Use the arrow keys to navigate when screen editing the above screen. Navigate to after the string on this screen that starts with linux, and add nouveau.modeset=0 to the end of the line. This change is only temporary — it will just be used once and GRUB won't remember it in the future. Press Ctrl+X or F10 to boot with the nouveau.modeset=0 option that was added. If you make a mistake, press Esc to go back to the previous screen.

Your system should start. After that, open the terminal and run the following commands to install the proprietary graphics driver.

sudo ubuntu-drivers install   
sudo reboot   

sudo ubuntu-drivers install installs drivers that are appropriate for automatic installation including their dependencies.

  • I am using acer nitro 5 with amd ryzen 2500u and amd radeon RX 560x graphics. And how do I enter the grub. Jun 2, 2019 at 9:36
  • I have not installed ubuntu yet on my pc. Its only on the usb drive. Jun 2, 2019 at 9:39
  • I replied to your comments by editing my answer.
    – karel
    Jun 2, 2019 at 9:44

If you are using the live boot on a USB drive, you can modify the first menuentry in the /boot/grub/grub.cfg as follows:

linux  /caspar/vmlinuz file=/cdrom/preseed/ubuntu.seed noapic noacpi nosplash irqpoll ---

This allowed me to boot Ubuntu without error.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .