0

Yesterday, I reformatted my Lenovo G580 laptop, and ran a clean installation of Windows 10. After the installation Bluetooth disappeared completely. I waited till all the updates are downloaded and installed. However, this did not install the bluetooth driver. Note that before this clean installation, I was running Windows 10 with Bluetooth perfectly working.

The Bluetooth disappeared from Device Manager. There is no entry containing Bluetooth in name, including the hidden devices. I tried to install the drivers from Lenovo's support website. As there are nothing available for Windows 10, I tried to install the ones for Windows 8.1, with compatibility mode set to Windows 8. But none of those drivers were installed due to the following compatibility issue.

Realtek Bluetooth suite can't run on Windows

I also tried correcting the Bluetooth Support Service, but nothing changed. I tried to troubleshoot Bluetooth as per Microsoft's official help page on this. The troubleshooter said that

Device does not have bluetooth

Bluetooth is not available on this device. Please try using an external adapter to add Bluetooth capability to this computer

Being clueless now, I tried to reset the BIOS to its default settings, as some of the internet articles and/or SE sites suggested. I have already seen this Option to Turn Bluetooth on or off is Missing and tried some of the suggested solutions. But nothing worked.

Please advise on how to solve this problem?

Additional details: I tried Ubuntu with a bootable USB, and bluetooth worked there like charm. However, when I logged back into Windows, it was still the same (no bluetooth).

Solution worked on my machine: I finally solved it by updating BIOS from here. I rebooted after installation, and the bluetooth is there in the device manager :)

  • Looking at Lenovo page there is plenty of drivers there, which one did you tried? You need to install the one corresponding to your manufacturer Bluetooth chip. – CaldeiraG May 30 at 11:51
  • @CaldeiraG I tried this one "Bluetooth Driver (Broadcom, Atheros)File Name: bt200w81.exe OS: Windows 8.1 32-bit, 64-bitVersion: 12.0.0.7620 (BTW 12.0.0.7800) / 8.0.1.300" – Sayan Pal May 30 at 12:57
  • In Device Manager (with hidden devices shown), expand Universal Serial Bus Controllers. Select USB Root Hub, then switch the view to Devices by connection. Are there any unknown devices showing? – Keith Miller May 30 at 17:06
  • @KeithMiller I tried that. There was an "unknown usb device (device descriptor request failed)". Uninstalled the device with the hope that the driver will be correctly installed on restart. That did not happen, and the device is now gone for good :( – Sayan Pal May 30 at 17:40
0

Longer method is to

use linuxmint/any linux with liveiso on USB (rufus is DD mode) boot from it.

once reached desktop run level run the commands

lsusb

lspci

capture all as text and look for text with bluetooth

usually lenovo has Atheros/Broadcomm for wifi/bluetooth

OR

shorter method try using DriverBooster/IOBIT

  • 1
    Thank you for your answer. However, none of these 2 work. I tried Ubuntu from a bootable USB. Bluetooth worked there, but it disappeared when I logged back in to Windows. And DriverBooster does not acknowledge existence of any Bluetooth device on machine. Therefore, there is no question of updating the driver. – Sayan Pal Jun 1 at 6:52
  • have you found out which was the bluetooth module from Linux ? – nizam Jun 2 at 6:34
  • 1
    It is Broadcom BCM20702 – Sayan Pal Jun 2 at 9:26
  • support.lenovo.com/in/en/downloads/ds031999, can you check if this helps ? – nizam Jun 3 at 13:14
  • 1
    Finally solved it by updating BIOS. Thank you for your help anyway :) – Sayan Pal Jun 4 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.