3

While trying to install TesgNG in Eclipse 2019-03 I got TestNG message as not compatible with Eclipse 2019-03.

TestNG incompatible for Eclipse 2019-03

2

Try Install this Eclipse. I installed another version that you and I had the same problem. But in the Eclipse IDE for Java developers TestNG is available. If u need more help, try this link too: https://www.toolsqa.com/selenium-webdriver/install-testng/

Eclipse IDE for Java Developers

1
  • This link should be used instead of this because of the redirect.
    – eLVik
    Nov 29 '19 at 9:06
1

Only these versions of Eclipse are supported now
Eclipse Versions: Oxygen (4.7), Neon (4.6), Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Photon (4.8), 2018-09 (4.9)
Java Version: Java 1.7+ is required for running the TestNG for Eclipse plugin.
For any update follow this link: https://marketplace.eclipse.org/content/testng-eclipse

1

I have solved this issue without upgrading eclipse.

Go to: https://testng.org/doc/download.html

And try to download the plugin via the eclipse market. https://beust.com/eclipse

If this did not work try to remove the s> http://beust.com/eclipse

1

Not the answer you're looking for? Browse other questions tagged or ask your own question.