1

Ive got an issue when exporting an Excel file form a Google Drive Sheet.

If i have a large amount of text / data in a cell in Google Sheets i use the wrap text feature so that all the text is displayed. The wrap text feature auto scales the line height of the row the cell is on, i order to accommodate the wrapped text.

See image below

screenshot from google sheets showing wrapped text

If i export this Google Sheet as an Excel file, By going to File > Download As > Microsoft Excel (.xlsx), and open in Excel for OSX v. 16.25 , the wrapped text looks like this (See image below) Note how wrapped text in Excel respects the line height of the row and dose not expand the cell.

screen from excel showing wrapped text

Ive noticed that if i set the line height in Google Sheets manually then export to Excel the line heights behave as expected.

Is there any way to change this so if someone receives an Excel file exported from Google Sheets they dont miss data in cells with text wrapping enabled ?

Ive shared a copy of the google sheet here, in case you would like to test (Please make a copy of this file if you would like to test with it.) https://docs.google.com/spreadsheets/d/1rLj0065fvlXC1mNPlO73_U9-KZ2gSHcX2tBdB18gBFI/edit#gid=1854366327

  • How are you exporting and to which format (CSV etc.)? – harrymc Jun 4 '19 at 19:13
  • @harrymc question updated to include the export method and format – sam Jun 5 '19 at 10:39
  • If the format of the Google Sheets exported to Excel is not suitable, maybe instead of giving out a Google Sheet URL, you could hand out an Excel spreadsheet containing VBA code to read this Google Sheet into itself with wrapped text, maybe even prompting the user for the URL. Would such a solution solve your problem? – harrymc Jun 6 '19 at 6:27
  • @harrymc i dont think it would, the plan is for lots of non technical users to use this document, and using VBA would over complicate it. I have had some success with setting the line height in Google sheets to "auto" which in certain circumstances rectifies the problem – sam Jun 6 '19 at 9:49
  • Then you already have the only solution which satisfies your criteria. So what do you expect of us? – harrymc Jun 6 '19 at 9:58
0

As a quick fix : Goto Home > Format > Cell size - Autofill Row Height (click this option for the selected cells/entire excel where above prob exists)

| improve this answer | |
-1

Try using OneDrive, SharePoint, or Office.com to host the Excel file. They won't mangle the file like Google is doing.

Google sheets and Excel files have different features. Not all features translate back and forth correctly.

Your other option is to open a bug report with Google and wait for them to fix it.

You can make a bug report in the Google Issue tracker: https://issuetracker.google.com/issues/65028011

| improve this answer | |
  • Google Sheets isn't mangling the file, Excel is. – Michael Frank Jun 9 '19 at 20:48
  • @MichaelFrank The way the Q reads is that the "Export to Excel" function of Google sheets isn't setting the "Wrap Text" attribute of the cells. The result is an Excel file, which Excel is the standard by which those files are measured. I'm not sure how you can imagine that Google is creating a valid Excel file that Excel isn't rendering properly. – HackSlash Jun 10 '19 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.