-2

How can Windows be so idiotic and obstinate about deleting files?

Currently I can't delete some files because Windows says they are open in a certain program, but that program isn't even running! I can even rename the exe file, and I still get the same error! I can check in Resource Monitor and those files and that program are not mentioned there. I tried using the Unlocker utility and it still can't delete it.

Last week I couldn't delete a network folder because Windows just couldn't bear to remove the thumbnails.db file inside it, for no reason of course.

This is 2019, Windows 10, I am tired of this nonsense. If Windows says it can't delete a file it should provide an option to terminate whatever process is supposedly using the file, and then it will try to terminate and realize it was being silly and get over it.

4
  • 3
    Yeah, it happens. What's the question? May 31 '19 at 1:50
  • 3
    Save your rants for reddit. May 31 '19 at 2:00
  • Lots of questions about that on this site, many with good tips: google.com/search?q=delete+thumbs.db+site%3Asuperuser.com May 31 '19 at 18:57
  • @HazardousGlitch The question was implied and, I thought, obvious: how to delete these files. Turned out I answered my own question, which might be helpful for people in the future.
    – Moss
    Jun 1 '19 at 7:41
-1

OK, well as soon as I asked the question, I answered this specific problem. I use a file launcher utility called Wox, which is what I used to open ("launch") some (but not all) of those files. I had a feeling that might have something to do with it so I killed that program and the files deleted no problem! Apparently even just searching for the files with Wox was enough to get them "stuck". And Windows lied to me about what program was using the files!

5
  • Why is the correct answer downvoted?
    – Moss
    Jun 1 '19 at 7:42
  • Probably because most of your question and answer was a rant and not helpful to others. And blaming one program for a problem that was caused by a different program. I'd either reword both to just the actual problem at hand or, better yet, delete the question. Jun 1 '19 at 10:46
  • The answer is not a rant. I don't know what you mean about blaming different programs. People should be aware that sometimes Windows doesn't accurately report which program is using a file. Also, what is wrong with rants? They are more interesting then a plainly worded question.
    – Moss
    Jun 4 '19 at 1:39
  • Because this site is about solving problems, not about rants. Rants are a waste of space and give zero help to the next person who might need help. The program Windows reported may have been what the problem program was using to do some of it's tasks. Jun 4 '19 at 11:40
  • Well, as I said, the answer is not a rant, and the "question" states the problem clearly, it just adds a little rant flavour, because this is really annoying Windows behaviour, and if somebody wanted to give a more general answer about why it is impossible for Windows developers to improve the situation or something like that, then that would be nice to know. Yes, it looks like there was some miscommunication between Wox and Windows as to file usage. I don't know why Resource Monitor showed nothing though.
    – Moss
    Jun 5 '19 at 23:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.