3

I commonly use TAB to move from the address bar to the search box in Firefox. However, I just recently noticed that it has started stopping at all the toolbar buttons in between rather than going directly between the two. I nearly certain it doesn't do this on my other PC (don't have it handy right now, but I'm pretty sure it is also on the latest FF). Was there a recent change to this behavior, or is Firefox on my home computer suddenly configured differently?

I am using Firefox 67.0 (64-bit).

  • tab order should flow from top-left -> bottom-right, for webpages in western-based languages, just as a general design principal. For me, the addition of the "View" toggle feature ("Toggle Reader View") puts an extra tab between the address bar and Search on FF 67.0. you can see if disabling it has any effect: support.mozilla.org/en-US/questions/1065043 . Also note, that reader view is not available on every page of every site (I don't see it on DDG), so the discrepancy may just be the content in question. – Frank Thomas May 31 '19 at 4:29
  • Thanks for the response; prior to version 67, I didn't hit any stops between the address bar and the search box, regardless of how many buttons appeared there. – glancep May 31 '19 at 13:51
  • to move to the search bar you can simply use Ctrl+K or Ctrl+E – phuclv Jun 1 '19 at 15:09
  • 1
    @phuclv - thank you, I was aware of and occasionally use Ctrl+K, but somehow my brain is currently wired to do Alt+D then TAB often enough that this was becoming an annoyance! – glancep Jun 1 '19 at 19:13
4

To disable this you need to set browser.toolbars.keyboard_navigation to false.

And now, the setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste TOOLB and pause while the list is filtered

(3) Double-click the browser.toolbars.keyboard_navigation preference to switch the value from true to false

https://support.mozilla.org/en-US/questions/1260534

| improve this answer | |
  • you are a scholar ant a gentleman (or woman). That worked perfectly--accepted the answer. Thanks! – glancep Jun 1 '19 at 19:11
1

I verified that my other PC this morning that is NOT exhibiting this behavior is on Firefox 66.0.4. Thus, I decided I should look over the version 67 release notes. From there, I found the following referenced link:

https://support.mozilla.org/en-US/kb/access-toolbar-functions-using-keyboard

According to that page, this is a new feature to allow full keyboard accessibility to all toolbar elements. So, this is a new feature; just not one that worked for me!

Unless/until I find a way to disable this, I'll go ahead and accept this answer.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.