10

Tried running Docker Toolbox on my Windows 10 Home 64-bit machine.

Virtualization is Enabled

also, Hyper-V is already enabled!

Hyper-V is enabled!

But when running the Docker Quickstart Terminal, it always shows "This computer doesn't have VT-X/AMD-v enabled. Enabling it in the BIOS is mandatory"!

5
  • In your second screenshot you are showing the Windows feature called Windows Hypervisor Platform. This is not the same as Hyper-V. Scroll up and you'll see a checkbox for Hyper-V. – n8te May 31 '19 at 6:55
  • You might have to disable Core Isolation in Windows Defender as well as it may "steal" VT-x/AMD-v: superuser.com/a/1366359/19943 – Mokubai May 31 '19 at 6:59
  • Please indicate which version you have installed, use winver, to determine that information. Your question cannot be answered without this information – Ramhound May 31 '19 at 11:55
  • I have Windows 10 Home 64bit Version 1809 – reiniellematt May 31 '19 at 23:27
  • 1
    Since you have Windows 10 Home Hyper-V cannot be enabled. You should edit your question to reflect that fact. It currently indicates you have enabled it. Is Docker Quickstart Termina part of Docker Toolbox or Docker for Windows? Edit your question instead of submitting a comment – Ramhound May 31 '19 at 23:45
10

I had the same problem. SVM ect. was enabled in my BIOS but the error was still shown. The answer by FantomX1 helped me to get going. Try this:

  1. Open C:\Program Files\Docker Toolbox\start.sh with an Editor

  2. Replace line 69 from

"${DOCKER_MACHINE}" create -d virtualbox $PROXY_ENV "${VM}"

to

"${DOCKER_MACHINE}" create -d virtualbox --virtualbox-no-vtx-check $PROXY_ENV "${VM}"

  1. Open Docker Quickstart Terminal.
  2. Done :)
2
  • 1
    It's line 69 in Docker Toolbox 19.03.1 (Jul 31, 2019). – Karsten Silz Jan 13 '20 at 9:38
  • thanks Karsten. I replaced the line number in my answer. – SergejoWizz Jan 15 '20 at 19:59
4

@SergejoWizz's answer contains the full location where to change the Docker toolbox start.sh file, however editing the file might not be desired every time, as one might reinstall Docker toolbox or install it on other computers, so you might want to create a temporal file shortcut with the provided --virtualbox-no-vtx-check parameter below.

Home Edition does not support Hyper-V I was able to use VirtualBox at Home but not docker inside virtualbox with the same message, yet, even when I upgraded to Windows Pro, I had the very same issue as you in spite of having UEFI (Bios) SVM = AMD-x version of VTX, I had disabled Hyper-V as it is possible only at Windows Pro version, but what seems to help me is running docker toolbox manually via command like this with a parameter --virtualbox-no-vtx-check docker-machine create -d virtualbox --virtualbox-no-vtx-check

1
1

But when running the Docker Quickstart Terminal, it always shows "This computer doesn't have VT-X/AMD-v enabled. Enabling it in the BIOS is mandatory"!

You can try the following solution.

Within an elevated PowerShell environment run the following command:

1) PS > bcdedit /set hypervisorlaunchtype off

2) You should verify Core Isolation is disabled.

Source: This computer doesn't have VT-X/AMD-v enabled. Enabling it in the BIOS is mandatory

Additionally, you should disable any hardware virtualization features, of any security products you might have installed.

Hyper-V is already enabled!

You absolutely DO NOT have Hyper-V installed on a Windows 10 Home installation.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.