1

On debian (testing) with gnome 3.30.2 I am unable to change the text-scaling-factor to 1.25. Neither the tweak-tool nor using the gsettings command works: Option grayed out As you can see on the screenshot the plus option is grayed out.

Using this command:

gsettings set org.gnome.desktop.interface text-scaling-factor 1.25

I get this error:

The provided value is outside of the valid range

Using the command line I can set the scaling factor to something equal to or below 1, but every value greater than 1 gives me the above error.

I am absolutely certain I was able to do this a few days ago. I do not remember installing any updates since then. Several reboots and logouts did not fix the problem. I would like to avoid uninstalling/reinstalling software since this is a relatively new debian install and I doubt it would help.

uname -a:

Linux T470s 4.19.0-5-amd64 #1 SMP Debian 4.19.37-3 (2019-05-15) x86_64 GNU/Linux

Are there any logs I can look at to see what's wrong? How can I make that option available again?

I have tried turning the "Large Text" accessibility option on but that didn't help either.

The file in /usr/share/glib-2.0/schemas/org.gnome.desktop.interface.gschema.xml contains:

<key name="text-scaling-factor" type="d">
  <range min="0.5" max="3.0"/>
  <default>1.0</default>
  <summary>Text scaling factor</summary>
  <description>
    Factor used to enlarge or reduce text display, without changing font size.
  </description>
</key>
<key name="scaling-factor" type="u">
  <default>1</default>
  <summary>Window scaling factor</summary>
  <description>
    Integer factor used to scale windows by. For use on high-dpi screens.
    0 means pick automatically based on monitor.
  </description>
</key>
  • Can you set in Tweaks > Fonts > Scaling Factor the value to 1.25 and restart? – harrymc Aug 25 '19 at 14:49
  • @harrymc As you can see on the screenshot the plus option is grayed out, also if I enter the number directly it resets to 1.00 when I hit enter. – technical_difficulty Aug 25 '19 at 15:28
  • What do you have in the XML file /usr/share/glib-2.0/schemas/org.gnome.desktop.interface.gschema.xml for the tag text-scaling-factor (add the tag to the post)? Do you have a line saying <range min="0.5" max="3.0"/>? – harrymc Aug 25 '19 at 15:42
  • Yes, I edited the question to include the content of that XML file – technical_difficulty Aug 25 '19 at 16:13
  • The contents seem correct. Change the <default> tag to 1.25, save the file, in su mode run the command glib-compile-schemas /usr/share/glib-2.0/schemas, then reboot. – harrymc Aug 25 '19 at 16:34
0

It seems that even though all the configs were right, the only solution was to reinstall Debian. It now works like intended. I suspect a gnome extension to remove the accessibility menu had something to do with it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.