0

Device: Dell Inspiron 15R SE 7520, with own SSD. Dual boot windows 10 & Ubuntu 18.04. No battery anymore (physically removed)

Situation: I wanted to live-boot a new Linux distro from USB. Insert the stick, boot to boot menu (f12). USB stick doesn't show up next to the other options, but there is an option to disable/enable secure boot (or at least I think that was what it said, disable or enable). I chose that option since I thought I remembered I had similar issues before that were solved by temporarily disabling secure boot.

The problem: after dis/enabling secure boot, pressed reboot. Power went off, but when it went on again, nothing happened except for the fan spinning up temporarily and the power button LED going on. No bios screen, no windows boot, not even the backlight going on. When I press the power button quickly when it is on, the system shuts down after half a second, indicating that no OS booted.

What I tried: power cycle multiple times. I tried to reset the bios by removing the CMOS battery and disconnecting AC power, pushing the power button for 30 seconds, leaving the battery out for half an hour or so. Reconnect the AC power, try to boot then, 5 bios beeps for missing cmos battery. When I put the battery in, still 5 beeps for missing bios battery. Disconnect AC, reconnect, click power button. System powers on (power button led on and ventilator blowing). After 1 second powers down by itself and after one second up again. Still nothing.

I also tried all f buttons, delete button. Control+escape during plugging in the AC does not work since the laptop is from before the Dell bios recovery tool era.

An external screen via HDMI also doesn't work, doesn't even see the cable as connected.

I'm at a loss for what to next. Does anyone else have a clue how one setting in the bios can mess everything up or how I can reset the bios in another way?

Kind of similar problem, but he fixed it by doing the bios reset with the CMOS battery: https://www.dell.com/community/Desktops-General-Read-Only/Dell-desktop-complete-blank-screen-after-setting-Secure-boot-ON/td-p/4210041

  • Probably just a coincidence. Have you tried reseating the RAM modules? – Appleoddity May 31 at 21:07
  • Yes, and without them, the bios beeps, but after reseating nothing is different. – JoostMeulenbeld Jun 2 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.