0

I have an old computer with Windows 10 installed in Legacy mode. I think the motherboard is too old for UEFI. The computer runs perfectly with windows 10 (I have also checked that every key of the keyboard works) but I would like to install ubuntu 18 on it and I cannot access the BIOS. I can press del, F10, F8, F2, esc but nothing works.

It seems to be a problem similar to How to get into BIOS when USB keyboard is not powered and have no PS/2 ports? but the solution does not work for me (I cannot hear the three beeps). I have also tried to remove the cmos battery and to reset the jumper.

I can use advanced startup but in the advanced options I do not have access to UEFI firmware: there is no corresponding button for legacy mode. If I click "Startup settings", the computer restarts again (at that point I have tried every keys for getting into bios with no effect) and it gets me to a screen from which I cannot do anything. My keyboard has no action on this screen even if the screen says that F10 should get me to more startup options.

I am running out of things to try, do you have any clue on what may be the problem?

Edit :

  • If I unplug the harddrive and plug a ubuntu usb stick I still cannot access the bios but the computer boots directly on ubuntu. I cannot install ubuntu from there since I have unplugged the harddrive
  • I have no PS/2 port and I have try to plug the keyboard on every usb port
5
  • You can access the firmware settings by using Advanced Startup – Ramhound Jun 1 '19 at 16:38
  • @Ramhound Probably not possible if Windows us in Legacy mode. Don't know, never tried, all my Windows have been properly installed ;) – user931000 Jun 1 '19 at 16:48
  • @GabrielaGarcia - Well I have and you access the firmware settings by using Advanced Startup. Additionally, installing in Legacy Mode, is absolutely both supported and results in a properly installed instance of Windows. – Ramhound Jun 1 '19 at 16:50
  • Installing any OS in Legacy when there's no reason for that it's highly debatable. But in this case it already is and hopefully the OP will be able to access it followed by your confirmation :) – user931000 Jun 1 '19 at 16:56
  • I have already tried Advanced Startup with no success. I have edited the question to make it clearer. – François Darmon Jun 1 '19 at 22:23
0

Reboot to firmware setup is simply not possible with BIOS (“legacy”) boot. Even on UEFI systems, it is not guaranteed to be available. See this topic on Unix SE for more details on the OsIndications EFI variable.

If you cannot seem to enter the BIOS setup, the easiest method is to disconnect the storage device that holds the operating system. This way, you won’t accidentally boot and some timeouts may be more relaxed.

If you have a gaming keyboard with N-key rollover or anything the like, it may not work while booting. Use a regular USB keyboard instead.

If you want a more specific guide, you’ll need to find out the make and model of the motherboard, for example using CPU-Z.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.