47

My monitor is 1920 x 1200 and the computer is running Windows 7.

Using VirtualBox and Ubuntu 10.04, the screen of the Ubuntu can only be 800 x 600 or 640 x 480. Is there a way to change that.

I resized the VirtualBox window and Ubuntu still thinks the max is 800 x 600.

8 Answers 8

43

Try installing the guest additions.

Inside the window holding your virtual machine you can go to one of the menu options and select to install guest additions. It will mount a CD in the virtual machine where you will be able to run the installation scripts from.

The article below describes the complete installation process in more detail:

Install VirtualBox Guest Additions on VirtualBox Guests

20

To solve this issue, open a terminal and run the following command:

sudo apt install virtualbox-guest-dkms
3
  • 4
    I’m getting `unable to locate package' May 18, 2022 at 8:11
  • @JulianWagner me also Jun 29, 2022 at 18:56
  • 1
    On my ubuntu server vm i had to run sudo apt install virtualbox-dkms
    – MrJ1m0thy
    Feb 8 at 15:29
4

I had this problem, and it was because my physical screen resolution is 1024x768.

Uncheck: View > Auto-resize Guest Display

2
  • 1
    Excellent! Having got it working once and then somehow breaking it without realising how, this fixed it. Thanks! Jul 9, 2012 at 10:08
  • Not sure why, but this option appears disabled on my VM (Ubuntu 18.04).
    – JCarlosR
    Oct 19, 2019 at 3:48
4
  1. Search for Terminal

  2. Open Terminal

  3. Type : Sudo apt-get install virtualbox-guest-dkms

  4. Wait Until It dones (if anything press enter,Y,OK

  5. if it done. type : Exit

  6. Restart your Ubuntu by clicking Shutdown then click Restart!

  7. If you have black screen wait for 5 minute or above .

  8. Insert Guest additions in your virtualbox.

  9. If it said Force Unmount or Unmount .. PRess Cancel!

  10. You i'll see its finished now! Press CTRL(right) + F

2
  • 2
    How is this different than earlier answers?
    – Dave M
    Oct 25, 2014 at 18:41
  • What!!! So you mean to tell me that you don't even have to run virtualboxLinux.run file in the guest addition iso file. I just did what you listed here and it worked....
    – ThN
    May 25, 2015 at 7:22
3

I had the same problem yesterday. Installing the Guest Additions in Ubuntu resolved the issue. This is the article I found on VirtualBox's official forum that describes how to install the Guest Additions in any Linux distros.

Howto: Install Linux Guest Additions + Xorg config

Once the installation was done and Ubuntu was restarted, Ubuntu was able to detect my host OS' (Windows 7) screen resolution and adjust automatically.

2

My answer is related to console mode Linux only. So, please be aware of that.

If you are using Linux with no X-Window installed (like usually servers do) than you'll need to edit /etc/default/grub file adding following lines:

GRUB_GFXMODE=1980x1200x32
GRUB_GFXPAYLOAD_LINUX=1980x1200x32

Then update grub config:

sudo update-grub

and reboot your VirtualBox instance.

2

If, like me, you have found this post and already have Guest Additions installed and are still having this problem even in Scaled mode, what worked for me is...

  1. Hit Host+C (for me Right-CTL + C)
  2. In the VBox header menu, go to: View > Virtual Screen
  3. Select the "Scale to [some percent] (autoscaled output)" option

(It should then scale to whatever size you've stretched the window to w/in a few seconds (if it takes more than 3 it's not working))

1

Update 2023

virtualbox-guest-dkms is no longer required.

I noticed a lot of the answers here are from 2010 and haven't been updated.

As @Julian Wagner pointed out:

If you run sudo apt install virtualbox-guest-dkms, you will get the error

Unable to locate package virtualbox-guest-dkms.

The correct solution for this is to ensure scaled mode is disabled on VirtualBox (View > Scaled Mode).

Then, after installation is completed, it's as simple as right-clicking on the desktop, going into Display Settings and selecting your preferred resolution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .