0

I can't successfully run any windows command from certain directories. These are Windows directories, not native WSL directories.

$ cd /mnt/f/Projects/ng/standalone2/
# no error:
$ explorer.exe .
$ cd /mnt/f/Projects/ng/android2/
$ explorer.exe .
Segmentation fault (core dumped)

I've tried using icacls.exe to erase any ICLs that could have been causing the problem. Newly created directories sometimes exhibit the problem, so I can't just copy everything and expect it to work from that point forward. I can't even run "git.exe help clone" (and I can't totally get away from using Windows executables).

How can I debug this? I am using Windows 10, version 1909 (build 18363.720).

5
  • Did you use latest fixed version 3.0.1.2? Did you add any /etc/wsl.conf file to configure settings? Try to use chmod and chown to fix WSL side. DO NOT use icacls or takeown.
    – Biswapriyo
    Jun 3, 2019 at 12:46
  • I upgraded wsltty but that did not fix the problem. And why do you tell people not to use icacls? I would have had to trash this computer multiple times if not for the saving hand of icacls. Chown/chmod do absolutely nothing when the windows side is broken. And I have options = "metadata" in wsl.conf. I used to have bind mounts and drives mounted in multiple places, but I removed those settings.
    – piojo
    Jun 4, 2019 at 2:43
  • @Biswapriyo Right, I don't use WSL files at all, except for config and scripts. Thanks for mentioning this to the developer! Though I've found a workaround, something weird is going on (and it may be a WSL bug).
    – piojo
    Jun 4, 2019 at 3:47
  • I and wsltty dev both tried. No issue at all. Try to reset or reinstall your wsl distro and wsltty.
    – Biswapriyo
    Jun 11, 2019 at 17:07
  • @Biswapriyo Thank you. Of course it's partially an environment issue, but I don't know how to pinpoint it. Thanks anyway.
    – piojo
    Jun 12, 2019 at 12:35

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.