1

The Bluetooth worked fine until I run Disable-NetAdapter * and then Enable-NetAdapter *. It was supposed to just turn OFF/ON all net adapters (including Bluetooth), but it actually disconnects the Bluetooth hardware (I guess it's a bug).

After these PowerShell commands, the Bluetooth only show in device manager in "view hidden device". And in device manager, each item listed under the BT I get Currently, this hardware device is not connected to the computer.

Someone having the same problem solved it by physically exchanging the Bluetooth hardware, with another one, and reboot. The BT reappeared. Then exchanging back with the first hardware worked: when he rebooted, the BT hardware was then recognized/reconnected.

Is there a PowerShell command to reset the Bluetooth hardware connection to the computer, and then try to detect it again?

To Microsoft: this bug seems related (and maybe the root of) this kind of issue.


  • the problem happens on Windows 10 1809, and also in 1903.

I tried:

  • uninstalling the Bluetooth driver, which was shown (before this in the device manager/hidden view) and reboot. Still no Bluetooth.

  • I tried to use this code (a modified version of Ben's code in this answer). When I run it sends the error, Start-Service bthserv, so run Get-Service bthserv | Start-Service. And when I run Ben's code again it output: Wi-Fi On.

  • 1
    If Bluetooth is somehow disabled using rfkill, you need the vendor-specific software for Windows to turn it on again. Alternatively, there may be a working switch in the Action Center (Win+A). – Daniel B Jun 4 '19 at 13:33
  • @DanielB thanks! but when the bug occurs, the Bluetooth hardware isn't detected, so there no switch shown. The switch only turns it ON/OFF. The problem I'm talking about it outright disconnects the hardware from the laptop (Dell Inspiron 3520). – JinSnow Jun 4 '19 at 14:43
  • @DanielB you need the vendor-specific software for Windows to turn it on again are you talking about the drivers or something else? (because I installed the drivers provided by an MS technician, and it did not works, somehow it works a few days after (I suspect a windows technician did remotely/secretly reconnected it) – JinSnow Jun 4 '19 at 14:46
  • 1
    No, I am talking about something equivalent to the Software Wireless Switch discussed here. On Linux, there’s rfkill. – Daniel B Jun 4 '19 at 14:50
  • @DanielB oh that looks very interesting! Do you think I could reconnect it to windows using a portable linux (or dual partition)? Or maybe reconnecting in Linuw would reconnect it also on windows? – JinSnow Jun 4 '19 at 14:59
0

I did not find the answer, but I wrote an answer for this question (the main thread about the bluetooth bug) that might help some people getting lost on this thread.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.